Skip to Content
avatar image
Former Member

Synchronising BI ABAP and Java support packages

This is the first time I've had to patch my EP Java Stack for our BI solution. I want to be sure I'm planning things correctly so I'm looking for some confirmation and advice please.

Currently: STANDALONE Java stack for portal with BI Base Services, BI Web App and BI Broadcasting connected to STANDALONE ABAP BI Backend. NOTE PLEASE: These are two physically separate installations and, in QA and prod, they exist on physically separate hosts.

Currently the critical Java components are at SP17 and project requirements need an upgrade to SP20 with patch or SP21. The ABAP BW is on SP18.

My reading of various SAP Notes suggests that I can simply download the Java SP21 SCA files and deploy them directly (without deploying SP18, 19 and 20 first as one would for an ABAP stack). Is that correct?

I looked at the PAM and note 1013369 to try to understand what, if any, dependencies exist between my Java SP level and the BI ABAP backend SP level. I am none the wiser for my reading. I very much suspect there is going to be a degree of interdependency between SP levels on the two stacks but I can't find information on the required ABAP SP level to work with Java BI support pack 21. Any pointers or advice would be appreciated.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Feb 22, 2010 at 06:14 AM

    Hi,

    Please carefully read this [SAP Note 1163789 - NetWeaver 7.0: BI Java Synchronized Patch Delivery Strategy|https://service.sap.com/sap/support/notes/1163789] to get more information.

    My reading of various SAP Notes suggests that I can simply download the Java SP21 SCA 
    files and deploy them directly (without deploying SP18, 19 and 20 first as one would for an ABAP stack). 
    Is that correct?

    As per this SAP Note 1163789,

    all corrections from a lower Support Package Stack number have also been provided on all higher Support Package Stacks. 
    These correction have been delivered as part of Java Patches on the respective Support Package Stack.

    Also refer this SAP Note 1072576 - Frequently Asked Questions: BI Java Support Packages/patches. As per this SAP Note,

    In SAP Note 1013369, there is a list of the permitted combinations of J2EE and ABAP Support Package Stacks. 
    All other combinations are generally not supported.

    Regards

    Bhavik G. Shroff

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 22, 2010 at 07:15 AM
    My reading of various SAP Notes suggests that I can simply download the Java SP21 SCA files and deploy them directly (without deploying SP18, 19 and 20 first as one would for an ABAP stack). Is that correct?

    That's correct. Java SP's are cumulative as opposed to ABAP.

    looked at the PAM and note 1013369 to try to understand what, if any, dependencies exist between my Java SP level and the BI ABAP backend SP level.

    SAP recommends to have JAVA/ABAP at same level. As you have two separate installation I don't think this necessary. But you may want to raise customer message with SAP for 100% correct answer.

    Add comment
    10|10000 characters needed characters exceeded