Skip to Content

SSF error: Decoding not possible occurring in function module SDOK_PHIO_GET_URL_FOR_GET

Hi experts,

I already tried to follow this post but the solution which is provided there doesn't work in my case.

https://archive.sap.com/discussions/thread/809784

I am developing an application to display an "original" PDF Document in the web browser.

So far I cloud create the URL of the original (see screenshot) with the function module which is mentioned in the title. But when I'm trying to use the URL in a web browser I'm receiving the SSF error.

Do you have any idea what could cause this behavior?

I already tried several web browsers and none of them work with the link. (It is no problem to display pdf documents in the browser which are not provided by the SAP system)

Are there better ways to display document "originals" in a web browser

instead of using "SDOK*_FOR_GET"

url.jpg (133.7 kB)
Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Best Answer
    Dec 10, 2018 at 05:29 AM

    Hello,

    Follow below steps to check the result:

    1) Execute Transaction OAC0
    2) Open Content repository DMS_C1
    3) Click on Full Administration
    4) Check the checkbox: No signature
    5) Save the Settings.

    Afterwards check whether SSF error still occurs.

    Also check:

    1) Execute transaction SICF

    2) Open the service /sap/bc/contentserver

    3) Go to tab Log on data change the Log in procedure to 'Required with logon data'

    4) Follow the same setting in External Aliases

    5) Change the user type to Service / Dialog user type

    6) Execute transaction CSADMIN

    7) Enter Content Repository as DMS_C1 and hit Enter

    8) Go to Certificates Tab Send and activate the certificate.

    As the Storage Type is Database, therefore the service /sap/bc/contentserver require authentication. See the note 685521.

    Check if the authentication works, as per note 685521, and performer further tests.

    Regards,

    David

    Add comment
    10|10000 characters needed characters exceeded