Skip to Content
author's profile photo Former Member
Former Member

UWL Error

Hi Pundits,

I have an issue with UWL. I use "Manage Substitution Rules" and assign my tasks to a user, say "USER A". It all works fine and since i dont need USER A anymore i delete him from the User's list. I then go and delete the rule that i created using "Manage Substitution Rules". It gives an obvious error that the User is not known, since USER A has been deleted, the rule created remains and does not get deleted.

Please help me to get rid of the unwanted rule from my UWL.

NOTE: I thought since the user USER A is deleted, the rule is not getting deleted. So i created a user with the same name as USER A. Now the rule gets deleted from UWL, but i feel this is not the ideal solution and there should be a better one.

Thank You.

Kind Regards,

Manoj Durairaj

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Feb 18, 2010 at 12:23 PM

    Hi Manoj,

    The ideal way to remove the Manage Substitution rule assigned to a User goes this way:

    (I) Navigate to "manage Substitution Rules".

    1. Select the SELECTION icon associated with the Assignee for whom you want to Turn Off the substitution rule.(The Substitution Rule will remain intact allowing the same rule to be Turned On again in the future.)

    2. Select the TURN OFF button.

    3. The system displays the message "Successful". This message indicates the Substitution Rule has been turned off. In addition, the TURN OFF button has been replaced with the TURN ON button.

    4. Select the SELECTION icon associated with the Assignee for whom you want to delete the substitution rule:

    5. Select the DELETE button.

    Now you can go ahead and delete this unwanted user.

    Hope this helps.

    Regards,

    Shailesh

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Dear all,

      we've the same problem in a higher release, and i search for a solution, because the user who has created the rule didn't now that the user was deleted. So did sap provide a solution, because i search in sdn and sapnet but didnt find a solution without user interaction. Create the user and delte the rule afterwards delete the user again is not a realy goog solution.

      Best regards

      Thorsten Stracke

  • author's profile photo Former Member
    Former Member
    Posted on Mar 23, 2010 at 08:52 PM

    Hello Everyone,

    Regarding the issue with Substitution - I can see that this issue will be resolved in EP 7 SP 22 (note is not released yet) and for EP7.01 UWLJWF SP06 patch 1 contains the fix. Development are aware of the issue and have fixed this in the releases mentioned above.

    Best Regards,

    Beth

    • Please see the UWL Wiki @

    https://www.sdn.sap.com/irj/scn/wiki?path=/display/bpx/uwl+faq ***

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.