Skip to Content
0
Former Member
Feb 17, 2010 at 08:26 PM

ADS - render operation exception error - XMLFM Exception

560 Views

Hello,

I am getting the following error on JAVA ADS whenever we use ADS. THis is coming sporadically, not all the time. daily we are getting this error around 10 to 20 times.

ECM Job runs on ABAP side which call ADS running on different host. ADS configuration is correct as same job works fine 80% of time.

Servers are also not over loaded.

Here is the log file

at com.sap.engine.core.cluster.impl6.session.MessageRunner.run(MessageRunner.java:41)

at com.sap.engine.core.thread.impl3.ActionObject.run(ActionObject.java:37)

at java.security.AccessController.doPrivileged(Native Method)

at com.sap.engine.core.thread.impl3.SingleThread.execute(SingleThread.java:104)

at com.sap.engine.core.thread.impl3.SingleThread.run(SingleThread.java:176)

Caused by: com.adobe.ProcessingException: XMLFM Exception - PDF render operation exception, reason code: 0 : Unhandled exception in RenderAll; [Error Log file "2010.02.16.153456SAFPRM99078.pdf" written to /usr/sap/ECP/SYS/global//AdobeDocumentServices/renderErrorLog/errorFiles]

at com.adobe.ads.operation.Render.execute(Unknown Source)

at com.adobe.ads.operation.ADSOperation.doWork(Unknown Source)

... 29 more

Caused by: com.adobe.ProcessingException: XMLFM Exception - PDF render operation exception, reason code: 0 : Unhandled exception in RenderAll

at com.adobe.ads.operation.support.RemoteRenderer.renderAllRemote(Unknown Source)

at com.adobe.ads.operation.support.RemoteRenderer.renderAll(Unknown Source)

at com.adobe.ads.operation.support.RemoteRenderer.renderAll(Unknown Source)

at com.adobe.ads.operation.Render.renderWithoutCache(Unknown Source)

... 31 more

Caused by: com.adobe.document.xmlform.RenderException: IDL:com/adobe/document/xmlform/RenderException:1.0

at com.adobe.document.xmlform.RenderExceptionHelper.read(Unknown Source)

at com.adobe.document.xmlform._FormFactoryStub.renderAll(Unknown Source)

... 35 more

There are lot of posts for this kind of error but no one has suggested any solutions. We are NW2004 S 7.01 SP3.

Any help ?

Thanks!