Skip to Content
avatar image
Former Member

Schedule Report to MS Sharepoint location fails (source file error)

Hi,

I am Using BO XI R2.

I would like to publish WEBI reports automatically in a Sharepoint environment. I had managed to get this to work. But since last weekend my schedules fail. What did I do in order to get this to work:

- Enabled the unmanaged disk option in the Central Management Console.

- Entered a standard location in UNC format (//intranet.*****-***.com/sharepointfolder) and password (DOMAIN\USERID ; password)

- Had the WEBCLIENT service enabled (in MS Windows Server 2003) or else it was not possible to connect to the webdav location.

- When I run command (cmd) and then check the sharepoint location I am prompted to log in. Because this sharepoint machine is on another domain I login with DOMAIN\USERID and password. I am able to browse and write this directory from the BOXI server environment.

- I have checked If I can schedule reports to a location on the C drive of the business Objects server. That works fine)

- When I schedule a report to the sharepoint location I get this error: source file error. CrystalEnterprise.DiskUnmanaged: Invalid argument.

The strange thing is that this had worked before. The only thing I can see is that our hosting partner patched the BO server environment with

- MS10-001 - Vulnerability in the Embedded OpenType Font Engine Could Allow Remote Code Execution (972270)

- MS10-002 - Cumulative Security Update for Internet Explorer (978207)

After this patch weekend it did not work anymore. Coincidence? I cannot see what these updates have to do with my schedule problem?

Any ideas would be very welcome!!

Edit:

Could this have to do with the account under which I am running the Web Intelligence Job Server - Service. It is running under LocalSystem (System account)? This localsystem account does not have any permissions on the Sharepoint location? But then again: it worked fine for about a few weeks.

Edited by: B. Vandenhende on Feb 16, 2010 2:43 PM

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    Feb 17, 2010 at 02:56 AM

    I've always thought the account running the webi report job server should be an AD account with permissions to write to the other server (where the reports get sent) Something needs write access to put files there. Not sure how this worked in the past without that.

    Regards,

    Tim

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 25, 2013 at 11:38 AM

    Hi

    I tried following steps still the issue persists :

    Create a registry entry AuthForwardServerList of type Multi-String Value at HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services

    \WebClient\Parameters\. Type the names of the computers hosting the

    SharePoint service as a list in the Value Data, one name on each line.

    click OK.

    Fyi.. This the error I get :

    login error. [Logon failure: unknown user name or bad password.]: [CrystalEnterprise.DiskUnmanaged]

    Verified that Username and Password are correct and user has Full Control on Sharepoint site

    Thanks,

    Miheer

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 25, 2013 at 02:00 PM

    Miheer

    Do you have a domain or local account running BusinessObjects?

    We had to create a domain service account with the necessary rights on SharePoint to run BusinessObjects.

    Since we have done this we can schedule to SharePoint.

    Regards

    Michael

    Add comment
    10|10000 characters needed characters exceeded