Skip to Content
avatar image
-1
Former Member

Advanced DSO SID generation

Hi,

I'm facing a problem when loading the data into an ADSO, the SIDs for the characteristics are not generated automatically. This results in wrong data in the reports on a composite provider - the records which contain the new values for which no SID's have been generated are not displayed at all.

Here are my settings of the ADSO:

...and these are the settings of every single characteristic:

Currently I'm using a workaround - running the RSRV check for the ADSO (Foreign key relationship of reporting-relevant DataStore object and SID table characteristics).

Am I missing something or is there a known SAP bug?

We are on 7.4 / SP13.

Thanks,

Marek

adso1.png (20.2 kB)
adso2.png (11.9 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Aug 31, 2017 at 10:09 AM

    Did you get the solution to above query, we have also faced the same issue.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 10 at 01:22 PM

    Hi, everyone.

    Same issue.

    As workaround, in ADSO objects' properties we've selected 'Master data check during reporting', and select 'Use structure elements' property in overlying Composite provider and Bex. Only this combo generate SIDs for the new values while reporting.

    Problem remains when we only load data to ADSO without reporting. Make ADSO standard-DSO-like with need of activating the requests does not help.

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 16 at 08:03 PM

    Hi,

    Did you check the following notes?

    2491697
    2536797
    2185212

    Regards,
    Erdem

    Add comment
    10|10000 characters needed characters exceeded