Skip to Content
1

BI Platform 4.2 Publication Documents Missing

Nov 25, 2016 at 01:36 PM

324

avatar image

Hello experts,

I have an issue with BI4.2. We recently upgraded one of our servers to BI 4.2 and are currently testing the new release. For one of our costumers, we publish Crystal Reports in a publication. The reports are merged together as pdf file. The destination of the publication is the Default Enterprise Location.

We are facing the issue that the publication is succesful, but there are no documents available when we select the instance time in the history of the publication. Normally and on our BI4.1 Servers, this view would list the pdf files.

The reports are transported via promotion management from a 4.1 Server and work well when scheduled as single Report on both Servers.

Does anyone can give me advice on how to fix this?

Regards,

Marius

10 |10000 characters needed characters left characters exceeded

We're having a similar issue after upgrading to 4.2 SP3. The publication says successful but not all files are generated. Sometimes zero are created and other times some get created. If I continue running the publication over-and-over, eventually everything will get generated. This is preventing me from automating the process and it has become time consuming. I've been looking for a fix for the last week or so.

0
* Please Login or Register to Answer, Follow or Comment.

8 Answers

Jawahar Konduru Nov 27, 2016 at 02:36 AM
0

If you are using publication, that means you need to send the output to email addresses, but why to 'Default enterprise location". Not quite sure why you are doing that way?

Share
10 |10000 characters needed characters left characters exceeded
Marius Margraf Nov 29, 2016 at 08:18 AM
0

Hello Jawahar,

I don't think you need to send the output to email addresses. "Our way" is working with BO 4.1 / our other BO systems.

However, we need to edit the output manually with Adobe Acrobat before sending it to our costumers. Because of this we don't send the output directly via email. I know that we could send the output to us via email, but I would prefer to stay on our current process.

Regards,

Marius

Share
10 |10000 characters needed characters left characters exceeded
Manikandan Elumalai Nov 29, 2016 at 05:10 PM
0

HI Marius,

Did you modify (Delete & Add ) the source documents in your BI 4.2 environment. Can we check whether the publication has same crystal reports (with Same CUID) and the user who is running the publication has access to both publication as well as all the source documents?

Thanks

Mani

Share
10 |10000 characters needed characters left characters exceeded
Marius Margraf Nov 30, 2016 at 08:25 AM
0

Hi Mani,

I didn't modified the source documents, the publication refers to the correct crystal reports (same CUIDs). The user who is running the publication belongs to the admin group and has full rights on the folders which contain the publication / the source documents.

I just want to point out again that the publication works, if I change the target to BI inbox for example I can access the output files. Just the target "Default enterprise location" doesn't seem to work like on our 4.1 servers, although the publication is finished sucessful. (When there are more than one instance, the option "view latest instance" works too, even if "default enterprise location" is selected as target). This is not a critical issue, nevertheless we would like to solve it.

The publication log doesn't contain any errors, I can only find the following lines in the log:

Running publication instance.
The global delivery rule for this publication was met; publication processing will now begin.
Publication scheduling complete.

(There is some more logging which is produced by a processing extension we use. We also tried running the publication without this extension to determine if the extension is responsible for this issue, but the behavior was the same.)

Regards,

Marius

Share
10 |10000 characters needed characters left characters exceeded
Marius Margraf Dec 19, 2016 at 12:46 PM
0

Hello everybody,

has anyone another idea on how to solve this issue? I haven't found a solution yet...

Regards,

Marius

Share
10 |10000 characters needed characters left characters exceeded
Dell Stinnett-Christy Dec 19, 2016 at 03:36 PM
0

Have you opened a ticket with SAP on it? It definitely sounds like it's a bug. Unless, of course, someone decided that this was the way it was supposed to be working all along, so it's now a "feature". :(

-Dell

Share
10 |10000 characters needed characters left characters exceeded
Marius Margraf Dec 21, 2016 at 08:58 AM
0

Hi,

no, I haven't opened a ticket with SAP on this issue yet. The server which is now on BI 4.2 is a test-system for upgrades, patches e.g. I guess I'll wait until one of our dev systems is upgraded and test the issue again - when the behavior is the same, I'm going to open a ticket.

In the past we noticed more than one time that our systems behave differently...

In the meantime, I'll execute the following steps for further analysis:

- create a successful running publication on a BI 4.1 system

- transport it to the BI 4.2 system via promotion management

- see if its running there and compare the properties of both publications with the BO Query Builder.

I'll update this thread when I have some useful results.

Regards,

Marius

Share
10 |10000 characters needed characters left characters exceeded
Marius Margraf Dec 22, 2016 at 01:23 PM
0

Hello,


here are my findings from my further analysis:


- I created a new publication with only one report on the BI 4.2 system. The report has just one simple textfield. Not even a datasource / connection. The error still comes up. I also changed the format to the original (crystal report), the behavior is the same.

- I created a new publication on a BI 4.1 system. This publication also contains one simple report without any data / connection. This publication is running successful ?with output format pdf and I can access the files when clicking on the timestamp in the publication history. Then I transported publication and report to the 4.2 system via promotion management and executed it -> the error still comes up.

- I followed the steps described in the master KBA for publication troubleshooting: https://launchpad.support.sap.com/#/notes/2127813
I wasn't able to find any errors / misconfigurations. I tried to follow the steps in the referenced kba
https://launchpad.support.sap.com/#/notes/2113583 to check the exact file location of the publication outputs. After executing a query with the query builder, I get the publication and it's instances as results, but none of them has a property "SI_Path". This applies for all above mentioned publications - even the working one on the BI 4.1 system.
- I also compared the results of the query builder in a text editor with a comparison plugin. My expectation was that there shouldn't be much differences besides server related properties (parent ID, etc.). However, I noticed that there are quite a lot properties added or deleted.

Regards,

Marius


Show 1 Share
10 |10000 characters needed characters left characters exceeded

Good find. Are we using any Custom Publication extensions?

0