Skip to Content
avatar image
Former Member

Configuration File - SAP GUI for Java

Hi,

My company runs on Windows platform for PCs and has some SAP systems. To access those we use the standard SAP GUI with saplogon.ini file.

Now we want to move on to UBUNTU and some employees doing Beta Testing..

We did following steps

1. Install Ubuntu

2. Install Java Runtine

3. Install SAP GUI for Java

Now when we are trying to configure SAP GUI to access SAP servers we hit a roadblock.

When we try to use the same INI file as for windows this GUI does not detect, in the help there is no new format of configuration file is provided.

We use both Message Servers and stand also IP based SAP servers.

Would appreciate if someone shares any information to connecting SAP servers with SAP GUI for Java.

Thanks,

Piyush

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Feb 12, 2010 at 06:07 AM

    Hi,

    Configuration file for SAPGUI is different on Windows and Unix...

    In windows, path of configuration file (saplogon.ini) is "\windows\saplogon.ini"

    In Unix, it is "/home/user/.sapgui/connection" (Under users's home directory...)

    To configure your SAPGUI for Java and test the SAP R/3 server connection, do as below

    1.Run executable file called guilogon (reside on /opt/SAPClients/SAPGUI700rev10/bin). It willpop up SAPGUI for Java window.

    2. Click New button.

    3. Fill the Description column as you like.

    4. Click Advanced Tab.

    5. Give check (V) to Use Expert Configuration

    6. Fill the connection string. If your server using load balancing configuration, use this connection string conn=/M/(IP_Address_Message_Server)/S/36(system_number)/G/(nama_group) and use this connection string configuration if yor SAP R/3 server are not using load balancing system, conn=/H/(IP_Address_server_SAP)/S/32(system_number).

    For Example:

    conn=/H/192.168.1.50/S/3203

    (Where 192.168.1.50 is a SAP server IP and 3203 is message server port for System No. 03)

    Make sure that you have installed JDK and added JAVA_HOME and JAVA_HOME/bin path in your PATH variable for each user.

    you can check with the below command...

    #echo $JAVA_HOME
    #echo $PATH
    #echo java -version

    Regards.

    Rajesh Narkhede

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 24, 2010 at 03:01 AM

    Hi Rajesh,

    This helps a lot. It would be helpful, if you were to clear some more doubts.

    Ques 1. The connection type is R/3 and Webdynpro. Where is the ECC connection? I mean we are in 2010 and R/3 is way outdated. Can you please explain.

    Ques 2. Can you please help me set up

    Gui Details

    Description u2013 Ecc 6.0

    Application server u2013 192.168.13.2

    System No u2013 00

    System id u2013 ECC

    I have set it up this way... conn=/M/192.168.13.2/S/00/G/ECC

    is this correct?

    Also I connect to SAP thru a VPN. Are there any extra steps I need to take other than setting up the vpn. Thanks.

    AJ

    Add comment
    10|10000 characters needed characters exceeded

    • Hello,

      ad 1)

      Would using "Web AS" instead of "R/3" as connection type be preferable? ECC is Web AS based, so please use connection type "R/3".

      ad 2)

      What you are trying to do is to use the application server as a message server. I am not sure if you have it set up this way.

      Also your port number seems to be wrong. If SID is 00, the port number of the application server would be 3200. Since you are connecting then directly to the app server, using a group would not work. In short, the connection string would be

      conn=/H/192.168.13.2/S/3200

      Regarding VPN, there should be no extras for the connection string. This is transparent once the VPN connection is working.

      Best regards

      Rolf-Martin

      P.S. please also consult chapters 7 and 9 of the manual part of SAP GU for Java regarding how to setup a connection to Web AS.