Skip to Content
avatar image
Former Member

SSO for SAPGUI using SNC

Is there a 64-bit version of the libgssapi_krb5.so available? When I point the snc/gssapi_lib to this file it fails to load. I am trying to set this up on a Solaris 5.10 Sparc 64bit box, and I thought a 32 bit file could still be read by the 64 bit system, but so far it can't.

I tried up dating my LD_LIBRARY_PATH, to include /opt/SFP/krb5-1.6.3/lib, as I thought it was an environment issue, but my unix support seems to think it is an issue with the 32bit lib not being able to be opened on our 64 bit system.

The error states "wrong ELF Class: ELFCLASS32"

Thanks,

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Feb 09, 2010 at 06:16 PM

    Thanks, I had been talking with UNIX about compiling it, but I wanted to be sure 64bit wasn't available. I'll share this link with them and see what they can do, I appreciate the help.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Markus Doehr

      We were finally able to get our domain support to create a user, and now that part works. The new error is another compiling error for another library, so I am working with UNIX again to compile it. Thank you for the help Markus.

      Edited by: David Harris on Mar 10, 2010 4:05 PM

  • Feb 09, 2010 at 06:07 PM

    > I tried up dating my LD_LIBRARY_PATH, to include /opt/SFP/krb5-1.6.3/lib, as I thought it was an environment issue, but my unix support seems to think it is an issue with the 32bit lib not being able to be opened on our 64 bit system.

    >

    > The error states "wrong ELF Class: ELFCLASS32"

    yes - because a 64bit program can't load a 32bit library.

    You can compile your own:

    http://osdir.com/ml/encryption.kerberos.general/2004-11/msg00007.html

    Markus

    Add comment
    10|10000 characters needed characters exceeded