Skip to Content
0
Former Member
Feb 09, 2010 at 03:03 PM

SSO to InfoView with IIS 7 problem

102 Views

Hello,

I couldn't find a answer to my problem in other threads. I read the dokumentation for this but one piece is missing since it is not funktion properly.

Description of Problem or Question:

I do get a Windows login promp when I configure Windows-Authentication in IIS 7. It asks for user-credentials of the IIS-Server-Host. (Which is also the CRServer) The only user accepted is the local administrator. I can't fugure out which peace of configuration is missing.

Where do I configure which type of authentication in IIS? I have several options (from top):

IISServername - Default Web Site - InfoViewApp - logon

I have tried every possible combination between Anonymous and Windows Authentication.

Product\Version\Service Pack\Fixpack (if applicable):

Crystal Reports Server 2008 V1 12.1.0.882

Relevant Environment Information (OS & version, java or .net & version, DB & version):

Windows Server 2008 (32bit), CMC: WACS, InfoView: IIS 7, (all on the same server)

SQL Server 2005

Windows XP Clients with IE8

Sporadic or Consistent (if applicable):

Consistent.

What has already been tried (where have you searched for a solution to your question/problem):

I searched this forum and some guides.

Steps to Reproduce (if applicable):

When I configure in IIS 7 everywhere Anonymous Authentication, then I get in InfoView login page the error: Account Information Not Recognized: Internal error. When I type in an domain user account the login works fine.

When I configure in IIS 7 for example at the Default Web Page (I don't know if this is the right place) and try to open the InfoView login page, I get before the page can open a windows login promt where it want's a login to IISServer or CRServer (which is the same). When I enter the local administrator of the IISServer then InfoView login page opens and I can access InfoView with a domain user. If I enter three times incorrect user credentials I get an HTTP 401 error.

By the way once logged in SSO2DB works fine. "Just" SSO2Infoview does not.

Please help since I think it's just a litte peace missing.

Edited by: Richard Martinek on Feb 9, 2010 4:21 PM