Skip to Content
author's profile photo Former Member
Former Member

Problem with export pack

Hi Luke,

I was having problems exporting to powerpoint and pdf so you advised me to install the export pack which I did and I am still having problems.

When trying to export to PDF i get the error:

09/02/2010 13:39: ERROR: PDF : generatePDF : HTML render is blank.

09/02/2010 13:39: ERROR: Printing : generatePDF : PDF conversion failed, no output PDF file was created.

and when trying to export to powerpoint I get and Active X problem saying that should install the office components cab. Which I have done so and it has created a new directory in the org chart folder and added a .dll to system 32 windows folder.

Is there somthing I am missing?

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

8 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Feb 09, 2010 at 05:33 PM

    Hi Luke,

    I forgot to mention that I haven't installed any service pack. Should I install service pack 2?

    Add a comment
    10|10000 characters needed characters exceeded

    • Installing one of the Service Pack's may solve the issue - I know that some of the CSS files need updating for the PDF to work correctly. I would advise installing Service Pack 2.0 because of the number of fixes and enhancements it provides to the application.

  • author's profile photo Former Member
    Former Member
    Posted on Feb 09, 2010 at 03:05 PM

    Hi Luke,

    The export pack installed itself (don't know where) but I have write permissions for both NETWORK SERVICE and EVERYONE on the entire ORG Chart directory.

    PDF is for org units and positions. There is no option to enable active X. Background printing is selected.

    Thanks

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Feb 09, 2010 at 02:26 PM

    Can you confirm whether any of the following apply?

    1) You have a folder called cds_jpg in your OrgChart folder

    2) You have Write permissions for NETWORK SERVICE on the Temp folder

    3) You have Write permissions for EVERYONE on the Temp folder

    4) You have ABCpdf.dll and ABCpdfCE4.dll in your Bin folder

    Thanks!

    Luke

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Feb 09, 2010 at 02:33 PM

    Hi Luke,

    1. Yes I do have the folder cds_jpg.

    2. I DO NOT have write permissions for NETWORK SERVICE on the temp folder.

    3. I do have witre permissions for EVERYONE on the temp folder.

    4. Yes the .dlls are in the bin folder.

    Could it be the write permission for NETWORK service on the temp folder.

    Thanks Luke

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Feb 09, 2010 at 02:42 PM

    Hi Luke,

    I have done that and te problems for pdf and powerpoint still occur. Does the active X need to be activated?

    Thanks

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Feb 09, 2010 at 02:52 PM

    Hi Luke,

    No difference. Powerpoint keeps saying there is an error with starting the active X object and the PDF log error is the same as I pasted in the first message to you.

    Add a comment
    10|10000 characters needed characters exceeded

    • Are the new files you've added from the Export Pack inherited the permissions from the parent folder (the OrgChart folder)?

      For PDF is this occurring with just orgunits showing and with orgunits and positions showing?

      For PowerPoint, have you enabled ActiveX in the browser settings?

      For both, have you selected the Print background colours option in the browser Advanced settings?

  • author's profile photo Former Member
    Former Member
    Posted on Feb 09, 2010 at 03:18 PM

    Hi Luke,

    Active X settings were okay, no difference with PDF at all. Still says HTML is blank. The office component has been installed and it sent a .dll to system32 file.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Feb 09, 2010 at 03:33 PM

    All export to image files are working. Do you think the nakisa office components cab is insatlled correclty?

    The office components is in its own directory with nakisa office components cab and nakisa.pot. Should these be here or somewehere else?

    Edited by: Smoothover on Feb 9, 2010 5:09 PM

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.