Skip to Content
avatar image
Former Member

Report Painter - Add Transaction code

Hi All;

I have created a variant of the report S_ALR_87013558 using the report painter transactions CJ1/2/3 and CJ4/5/6 (Not GRR1). The report is working fine.

I now want to attach a transaction code to the report to make executing it faster and more effective. I have searched the forum and I know that I should follow the following steps:

To create a TCode, follow the steps below.

1) Go to Transaction code SE93, Enter TCode Name and Press Create.

2) Give short Description and select Parameter Transaction, Press Enter

3) Select Transation Radio Button and write START_REPORT in the next text box Also Check the box Skip Initial Screen.

My problem comes into play when one considers the paramaters that I should enter at the bottom of the screen. I have tried to copy the same setting as S_ALR_87013558 but it did not work. The following also does not work :

On the bottom of Screen (default Values), Enter Parameters

i) Name = D_SREPOVARI-REPORTTYPE. Value = RW

ii) Name = D_SREPOVARI-REPORT Value = Your Report Group Name (Say ZGrp)

Your feedback will be appreciated.

Werner

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Feb 09, 2010 at 03:41 PM

    I have ensured that all the settings are as specified but now I get an error "Report does not Exists" ?

    Could it be due to the fact that it is assigned to the Package $TMP?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      HI Psconsultant.

      thanks for your reply.

      1. I have included START_REPORT in transaction field.

      2. Checked the SKIP INITIAL SCREEN

      3. Check the INHERIT GUI ATTRIBUTES.

      4. Selected Radio Button PROFESSIONAL USER TRANSACTION

      5. Checked all check boxes for GUI SUPPORT.

      in the Default Values

      D_SREPOVARI-REPORTTYPE = RE

      the problem is with D_SREPOVARI-EXTD-REPORT

      if I type as KP01RPSCO_X12KST1A (without sapces) the report is not working. If I execute the t.code it says

      REPORT NAME DOES NOT EXISTS.

      if i type as KP 01RPSCO_X 12KST1A (with 23 spaces) and click on SAVE button(in SE93) it throws error msg

      DO NOT USE BLANK CHARACTERS

      Edited by: Mr A on Feb 19, 2010 4:39 PM

  • avatar image
    Former Member
    Feb 09, 2010 at 02:37 PM

    Hello,

    The Value for D_SREPOVARI-REPORTTYPE should be RE not RW. Please try that.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 09, 2010 at 03:05 PM

    Hi;

    I have updated the first parameter and I have made some progress, however when I execute the transaction now I need to select and Application Class and then specify a Report Type.

    Can you perhaps indicate what other parameters I should enter and their value? Perhaps this will help.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Did you check the check boxes under GUI Support? These should be checked.

      Transaction Classification should be "Professional User Transaction"

      The "Inherint GUI attributes" should be checked under Classification

      The default Values

      D_SREPOVARI-REPORTTYPE RE

      D_SREPOVARI-REPORT

      D_SREPOVARI-EXTDREPORT KP 01RPSCO_X YOUR REPORT NAME

      D_SREPOVARI-VARIANT

      D_SREPOVARI-NOSELSCRN

      Try this. Should work

  • avatar image
    Former Member
    Feb 10, 2010 at 08:17 AM

    Hi;

    I was able to resolve the issue. I had to input the exact number of spaces as per report S_ALR_87013558 (23 to be exact).

    Thanks for your help on the matter.

    Kind Regards;

    Werner

    Add comment
    10|10000 characters needed characters exceeded