Skip to Content
author's profile photo Former Member
Former Member

NF-e com Process Status 02 e 04 (GRC)

Boa tarde Srs,

Hoje pela manhã deparamos com um erro estranho.

Algumas notas criadas estão em Waiting (J1BNFE).

Em NF-e Monitor, algumas estão com process status 02 e outras com process status 04.

Já tentei indentificar o erro pela SMQ1 e SMQ2 sem sucesso.

Também acessei o SXMB_moni e não consegui localizar nenhum log de erro.

E Message Monitoring (RWB), todos status estão em sucessful. Pela SM37, o Job /XNFE/UPDATE_ERP_STATUS está funcionando perfeitamente e todos os serviços estão ativos.

Alguém já passou por algo parecido e poderia dar uma dica para eu resolver este problema?

Agradeço imensamente toda e qquer ajuda.

Ricardo,

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Feb 08, 2010 at 06:12 PM

    Ricardo, boa tarde.

    Se:

    a) A nota esta com status 02 (sem lote) - Provavelemente o programa /XNFE/PROCESS_REPORTS não esta rodando (deveria estar rodando em um JOB.

    b) O lote esta com status 02, esta com erro ? Se sim: reenvie pelo monitor GRC, aba Lote.

    obs: Na J1BNFE vai ficar aguardando até o retorno da SEFAZ para o GRC.

    Isso é Homologação ou Produção? Se o erro esta no lote, verifica se a SEFAZ esta no ar. Se tiver, reenvie o lote.

    At.,

    Bernardo Braga

    Edited by: Bernardo Braga on Feb 8, 2010 7:13 PM

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Feb 08, 2010 at 06:54 PM

    Bernardo,

    Já existe um job escalonado para este report, e funcionando perfeitamente. Estou monitorando ele via SM50.

    O ambiente é produtivo. Notei que não está gerando númeração de lote (Batch) e não está aparendo o icone de reenvio (Status Query).

    Fernando,

    Pela SXMB_MONI não possui nenhum PE na coluna Outgoing; Todas as bandeiras estão quadriculadas e a maioria com ACK. Status (No errors in acknowledgment), outros com pontos de interrogação (verde). E na SMQ2 realmente não encontrei absolutamente nenhum erro.

    Estamos tendo um impacto absurdo, pois a área funcional precisam faturar e solicitei que parassem de enviar notas, até que o problema seja soluciononado.

    Agradeço imensamente toda ajuda possível.

    Ricardo,

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Feb 08, 2010 at 06:21 PM

    Na SXMB_MONI, procure a entrada referente à interface de inicio do processo (por exemplo, a 1a msg da inteface SIGNN, BATCH ou BATSR), role a barra pra direita e, na coluna Oubtound, procure pela palavra "PE". Veja a cor da bandeira do lado da palavra "PE"; isso indica o status de execucao do BPM: verde = escalonado; vermelho = executado c/ erro; quadriculada = executado c/ sucesso.

    Se tiver erro, clique sobre "PE" e isso vai abrir o log de execucao do BPM (vc tb consegue isso pela SXMB_MONI_BPE).

    No graphical workflow, vc vai poder ter informacoes do step que falhou e da causa do erro. De qq maneira, vc deveria ter o ack negativo de volta para o application system; se nao está voltando, pode ser erro na HTTP destination PI -> GRC (ou na configuracao do comm channel XI Receiver).

    Se tiver c/ sucesso ou escalonado (scheduled), vc deveria ver na SMQ2 ou a entrada do BPM schedulada (se tiver verde; fila XBPE) ou a entrada da msg que deveria ter voltado mas nao voltou ainda (filas tipo XBTO/XBTR*).

    Abs,

    Henrique.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.