Skip to Content
0
Former Member
Feb 08, 2010 at 02:15 AM

Crystal Reports Server 2008 V1 on RHEL after restart failed to start

15 Views

I have installed Crystal Reports Server 2008 V1 on RedHat Enterprise Linux (5.3), with all default settings (mysql, tomcat). And the server worked fine without any issues after installation, could able to view the sample reports as well.

But while trying to configure ODBC, I have restarted the machine. And from than was not able to start the server again. Found that mysql hadnu2019t started by default, hence started by going to the CRS folder u201Cmysql inu201D and given the below commandu2026

./mysqld --basedir=/data2/crystalreportserver/CRS2008V1/bobje/mysql --datadir=/data2/crystalreportserver/CRS2008V1/bobje/mysql/data --language=/data2/crystalreportserver/CRS2008V1/bobje/mysql/share/mysql/english -start

It gave below error messages, but startedu2026

./mysqld: Can't create/write to file 'art/ibeuVs8M' (Errcode: 2)

100207 19:38:34 InnoDB: Error: unable to create temporary file; errno: 2

100207 19:38:36 (Note) ./mysqld: ready for connections.

Version: '5.0.46-enterprise' socket: '/tmp/mysql.sock' port: 3306 MySQL Enterprise Server (Commercial)

Than went to CRS u201Cbobjeu201D folder and executed u201C./ccm.sh -start allu201D It shown the message starting all server and Starting the Server Agent Node. When tried to view the status of the servers, by using u201C./ccm.sh -start allu201D it saysu2026

Creating session manager...

Logging onto CMS...

err: ERROR Couldn't logon to CMS (STU00152)

err: Error description: The system <<MachineName>> can be contacted, but there is no Central Management Server running at port 6400.

Tired to access the CRS admin URL with no luck u2026 Any help would greatly appreciated...