Skip to Content

Field name is not known at runtime after upgrade to VS2017

Everything was running fine back when I was using VS2010 with the corresponding CR Engine. I used ODBC(RDO) through DSN to fetch fields in creating my report. It ran smoothly. My application ran for a year without any problems.

Last week I decided to upgrade to VS2017 so I could use Tasks in my coding. So I installed VS2017 along with the corresponding CR Engine (13.0.24.2970 is currently installed). Then hell broke loose. I keep getting "Field name is not known" during runtime. The worst part is, it only happened in one report (I have 18).

Things that I've tried:

  1. Verify Database, The database is up to date. Didn't sovled the problem.
  2. Set Datasource Location. Tried making a new connection through ODBC(RDO) using my DSN. I even tried recreating my DSN. Didn't sovled the problem.
  3. Tried recreating my report. It showed the the rows etc. on runtime. But the moment I started using the fields in formulas, the problem reoccurred. I swear to God I double checked the field names properly, the french brackets, the variable names used, the syntax. Nothing. The fact the report used to work means that the problem may not be on the formulas I created.

I need help, please. I'm so desperate I went beyond page five of my Google search.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Dec 03, 2018 at 07:29 PM

    Hi Jerome,

    What type does Crystal show the field as when you browse it? If the error only happens when you use the field in a formula then that indicates an problem with the data type.

    Formulas have a restriction for using certain types of data types. If you create a new formula, can you see the field in the field browser? If you can't but it should be then I'd suggest making sure you are using the latest ODBC driver for your database.

    When you say runtime, can you view the report in Crystal Reports, when you are debugging your application or after you deploy your application?

    Thanks,

    Brian

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 27, 2018 at 03:45 PM

    Hi Jerome,

    Download this test app:

    https://blogs.sap.com/2016/02/17/how-to-parameters-in-crystal-reports-for-visual-studio-net/

    In the drop down box there is an option to select "Formula"

    In that routine it will check all formulae in your report, look for the error counter.

    It will tell you if your formulae have any issues that need to be fixed.

    You may need to log on first

    Don

    Add comment
    10|10000 characters needed characters exceeded