Skip to Content

Application Failed to start because it's side-by-side configuration is incorrect SAP 2016

sap-crystal-reports-error.jpg

I've installed SAP Crystal Reports on two separate new machines. Two separate licenses. Clean install with no errors during install. When launching from the start menu, nothing happens. If you go to file location and launch from there, with or without running as administrator, we get the error stating "The application has failed to start because its side-by-side configuration is incorrect. User access control is turned off on both computers. Users are local admins on the PC. I can't seem to get any support from any source on this. I have googled the issue and have tried every possible solution found to no avail. I have uninstalled, rebooted, and then reinstalled twice on one of the machines. Same issue no matter what I do. I need help with this. It's critical that my users are able to work and do their jobs.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Posted on Dec 04, 2018 at 04:45 PM

    This error appears because a MS C++ library is missing. Which service pack of CR2016 are you using? If it's SP3 or older, you'll need the 32-bit Microsoft C++ 2005 redistributable which you can download here. For SP4 and newer, you'll need the 32-bit Microsoft C++ 2010 redistributable from here.

    Unfortunately, my experience has been that Crystal won't just start working once you install one of those - it has to have been installed prior to installing Crystal. So, here are the steps you need to take:

    1. Uninstall Crystal

    2. Install the C++ package

    3. Install Crystal again.

    -Dell

    Add a comment
    10|10000 characters needed characters exceeded

    • No cigar! It is SAP Crystal Reports SP2

      I uninstalled it. It required a reboot so I did that. I went to the link you provided and downloaded the 32-bit Microsoft C++ 2005 redistributable and installed it. Then reinstalled SAP and instead of launching from the shortcut, I went to the executable and ran as administrator. The same error came up. I'm at wits end here.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.