Skip to Content
avatar image
Former Member

SLDCHECK error

Dear Experts,

I tried to connect one of my ECC system to central SLD.

I have configured and created neceesary RFC connections,

But when i execute SLDCHECK, It is giving the following error

Calling function LCR_LIST_BUSINESS_SYSTEMS

Calling function LCR_LIST_BUSINESS_SYSTEMS

Retrieving data from the SLD server...

Function call returned exception code 4

=> Check whether the SLD is running!

Summary: Connection to SLD does not work

=> Check SLD function and configurations

Could you please tell me, how can i solve this issue.

Thanks and Regards

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • avatar image
    Former Member
    Feb 03, 2010 at 10:31 AM

    First check if you are able to reach SLD page. Then see if it is running. If not then start it.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 03, 2010 at 02:56 PM

    Purna,

    Your SLDCHECK should work even frm the backend system .

    If you have properly configured with tx "SLDAPICUST"

    Defined the two rfc's SAPSLDAPI and LCRSAPRFC

    In SLDAPICUST put in your SLD Host name and port properly

    and confirm that the 2 rfc's are working fine with a test connection

    If they arent working also confirm whether the JCO rfC provider in the sld host has both the programs running (sapsldapi and lsrsaprfc"

    Also check whether the password that u have given in sldapicust is working in the target SLD host ( it shouldnt be locked and should have the right password)

    Gerard

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Dear All,

      Thank you very much for your detailed replies.

      SLDCHECK in ECC is working fine ,once after i changed the username to SLDDSUSER and its pwd. By default other user is existed which do not have proper permissions to retrieve the data from central SLD.

      thanks and Regards

  • Feb 03, 2010 at 10:26 AM

    Hi,

    Did you made entry of SLD in RZ70 of ECC system ???

    Thanks

    Anil

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 03, 2010 at 04:40 PM

    Purnachender,

    If you check in SM59 for a TCP/IP Connection called LCRSAPRFC, you should be able to test this RFC to see if it is working correctly.

    I don't agree that this would only be configured in a PI system. If you have a system that needs to access the business systems on a PI landscape this would be configured. This RFC should function as a registered server program. In your PI system you would have a JCo connection with this RFC configured to a particular Program ID. You can bring up Visual Admin in your PI system and check the JCo connections to see if this is configured. If not you can configure it.

    For complete setup check:

    http://help.sap.com/saphelp_nw70/helpdata/en/be/6e0f41218ff023e10000000a155106/frameset.htm

    One thing to note is that if only the piece that is failing is the "LCR_LIST_BUSINESS_SYSTEMS", this only means that it cannot see the business systems in your PI system.

    You can test if this is ACTUALLY working by going into SE37 and executing the function module "LCR_LIST_BUSINESS_SYSTEMS", see if brings anything back

    I have expirenced in my systems that sometimes this check fails but everything seems to be working fine. I execute the function module and it seems to test fine, however it errors in the SLDCHECK. Why that happens, I may never know.

    I hope this is helpful,

    Shawn

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 03, 2010 at 05:25 PM

    Hi

    I presume your SLD is up/online and other systems are sucessfuly working fine.

    And coming to your issue, ensure below 3 items in your ECC system.

    1. goto transaction SLDAPICUST - ensure you have mentioned the correct SLD name, Port, User, Password

    2. goto transaction SXMB_ADM - ensure correct details like Role of Business System set to "Application System" & its corresponding RFC (which is basically rfc that points to your PI system)

    Note - This means your H type PI rfc also has to work fine.

    3. Ensure, you have Business System for your PI defined correctly (for example INTEGRATION_SERVER_<SID>)

    Regards

    Sekhar

    Edited by: sekhar on Feb 3, 2010 6:26 PM

    Add comment
    10|10000 characters needed characters exceeded