Skip to Content
0
Former Member
Feb 02, 2010 at 05:35 PM

Doubled records after logic execution

13 Views

Hi all,

I am experiencing strange behaviour in a logic file. What happens is that if I run the logic most of the times it runs correctly, but if I run it a couple of times, there are strange values coming into the database.

What the logic does is this:

First it clears all records using rec(factor=0) and after that it recalculates the values. Most of the times this is going as expected, returning the correct values. However, if I run the logic multiple times, after about the 4th time, the values begin to double.

I already added the following settings to the appset parameters:

THREAD_MAXNUM_SG: 1

INTERVAL_CHECK_SEND: 2000

MAXCELLS_THREAD_SG: 1000000

UNITPER_SP: 1000000

logicIs there anything else I can check? It doesn't seem to be an error in the logic syntax, as it works most of the times, but my gutfeelings says there is some error with the cleared values not being recognized by the remaining of the logic.

For example, this afternoon it ran ok for 4 hours, after which suddenly the issue re-appeared.

Kind regards,

Tim Vierhout