Skip to Content
0
Former Member
Jan 29, 2010 at 02:24 PM

NetWeaver crashes while deploying

96 Views

Hi,

I have to convert an enterprise application using JSF, Spring, Tiles and some other libraries from WebSphere to NetWeaver. So I removed all IBM related content and replaced everything with open source libraries to make it run on an Apache Tomcat server. So there are no more dependencies to any IBM libs. But with all the MyFaces, Spring, etc libs attached, the application got very huge. The EAR file is about 55mb including all jar files.

For testing purposes I have installed the CE7.1 Preview in a virtual machine (2GB of dedicated RAM, Access to both processors of the host machine). I can deploy and run small EARs without any problems. But when trying to deploy the big EAR, at first it takes a REALLY long time and fails with the following error in the deployment log

--- Deploying file(s):

<MyEARFile>

--- Status:

Deploy Exception.

--- Description:

S U M M A R Y

~~~~~~~~~~~~~~~~~~~

Successfully deployed: 0

Deployed with warnings: 0

Failed deployments: 1

~~~~~~~~~~~~~~~~~~~

Error. Check your available working servers. Error message: server crashed while processing the request

1. File:<MyEARFile>

NULL

Deploy status:Initial

Version:null

--- Exception:

com.sap.engine.services.dc.api.deploy.DeployException: [ERROR CODE DPL.DCAPI.1027] P4ConnectionException.

Reason: Error. Check your available working servers. Error message: server crashed while processing the request

at com.sap.engine.services.dc.api.deploy.impl.DeployProcessorImpl.deployItems(DeployProcessorImpl.java:757)

at com.sap.engine.services.dc.api.deploy.impl.DeployProcessorImpl.deploy(DeployProcessorImpl.java:226)

at com.sap.ide.eclipse.deployer.dc.deploy.DeployProcessor70.deploy(DeployProcessor70.java:112)

at com.sap.ide.eclipse.sdm.threading.DCDeployThread.run(DCDeployThread.java:122)

Caused by: com.sap.engine.services.rmi_p4.P4ConnectionException: Error. Check your available working servers. Error message: server crashed while processing the request

at com.sap.engine.services.rmi_p4.P4ObjectBrokerClientImpl.getException(P4ObjectBrokerClientImpl.java:743)

at com.sap.engine.services.rmi_p4.P4ObjectBrokerClientImpl.getException(P4ObjectBrokerClientImpl.java:725)

at com.sap.engine.services.rmi_p4.Parser.newRequest(Parser.java:148)

at com.sap.engine.services.rmi_p4.ClientConnection.run(ClientConnection.java:395)

at java.lang.Thread.run(Thread.java:595)

{/code}

Afterwards the Web Interface is no longer reachable and I have to restart the CE1 system.

Any ideas how I can fix that, to be able to deploy this Application onto NetWeaver?

Would be really great to get some help,

Thanks in advance,

Klaus Zanders

edit OK, trying it another time, an OutOfMemoryException showed up. So maybe those 2gb aren't enough. I will give it a bit more and try again, on monday.

Edited by: Klaus Zanders on Jan 29, 2010 3:28 PM