Skip to Content

Connection Server does not start

Hello guys,

The Connection Server does not start anymore.

When I always try to start it returns me a failed status and shows me that the server is considered failed because it has stopped 5 time(s) in 60 minute(s).

It's a BOE XI 3.1 SP2 with IK 3.1 SP2 installed on a Windows 2003 Server.

BO XI database is on a SQL Server and all tables are there and seems to be OK

The log file for the connectserver via trace is below :

2010/01/28 19:06:43.339|>>| | | 4524|4528| |||||||||||||||TraceLog::Admin: logdir ('C:/Program Files/Business Objects/BusinessObjects Enterprise 12.0/Logging/')

2010/01/28 19:06:43.339|>>| | | 4524|4528| |||||||||||||||TraceLog::Admin: update ()

2010/01/28 19:06:43.339|==| | | 4524|4528| |||||||||||||||TraceBridge::Initialize: pullable set to 1

2010/01/28 19:06:43.339|==| | | 4524|4528| |||||||||||||||TraceLog state:

// device_info

// ___________

// process (process#pid) = ConnectionServer#4524

// device (name#deviceid) = ConnectionServer#MainDevice

// pull/push (pullable) = Pull

// pull mode settings

// __________________

// configfile (ini) = C:\Program Files\Business Objects\BusinessObjects Enterprise 12.0\Logging\logConfig\BO_trace.ini

// every ... s (period) = 60

// config

// ______

active = true;

severity = 'W';

importance = '<<';

keep = true;

always_close = false;

log_dir = "C:/Program Files/Business Objects/BusinessObjects Enterprise 12.0/Logging/";

2010/01/28 19:06:43.402|==| | | 4524|4528| |||||||||||||||SIServerController:run: Fail to initialize or uninitialize. Reason is The root server reported an error Unknown.:

2010/01/28 19:06:43.402|==| | | 4524|4544| |||||||||||||||SIServiceStopThread::run: SIServiceStopThread::run exited

2010/01/28 19:06:43.402|==| | | 4524|4528| |||||||||||||||CsContainer::uninitialize

2010/01/28 19:06:43.402|==| | | 4524|4528| |||||||||||||||TransientObjectMonitor stopMonitor()...

.\siserver.cpp:974: TraceLog message 11

2010/01/28 19:06:43.402|>>|A| | 4524|4528| |||||||||||||||assert failure: (.\siserver.cpp:974). (false : SIServerController::run: Unknown exception caught in server's uninitialization function).

Any help please?!

thank you very much.

Cesar

Add a comment
10|10000 characters needed characters exceeded

Related questions

9 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on May 07, 2010 at 01:28 PM

    Hi

    I remember facing the similar issues long back on XIR2 at the customer site. I was a BO consultant at that time, I am now working on Cognos.

    The culprit was a configuration file called cs.cfg. I replaced it with same file from another BO setup and it worked. I was working on a production issue at that time. This troubled me for few days and finally I was able to track down to this file. after replacing this it worked perfectly.

    I don't remember the exact file location.

    Cheers

    Loki

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Feb 26, 2010 at 03:05 PM

    Have you tried to delete the connection service and create a new one? Looks like the connection service got corrupted somewhere along the line. Have you also tried to restart the server(s) or the SIA?

    Hope this helps...

    Martijn van Foeken

    Focuzz BI Services

    http://www.focuzz.nl

    http://nl.linkedin.com/in/martijnvanfoeken

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Mar 02, 2010 at 01:48 PM

    hi

    Also Try,

    The data access pack of the CMS database might not be installed.

    open Control Panel > Add/Remove Programs

    Highlight BusinessObjects Enterprise XI, then click on the Change button

    install the data access pack of the connection server corresponding of the CMS database

    Change Choose Modify Choose Data Access Select the type of CMS database and finish the install

    Regards

    Karthik

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on May 07, 2010 at 07:41 AM

    Hello,

    I have the same problem (Connection Server does not start).

    I'am under BOXI R2 SP6 (unix) and i have this error in my log when i want to start ConnectionServer :

    Timestamp ProcessID ThreadID Message

    [Fri May 7 07:37:09 2010] 31154 1103673168 Log: level=3 cat=1 msg=35100 p=ConnectionServer started

    [Fri May 7 07:37:09 2010] 31154 1103673168 trace message: SIServerController::run: Before initialize

    [Fri May 7 07:37:09 2010] 31154 1103673168 (sidaemon.cpp:416): trace message: SUNIXDaemon::init: starting

    [Fri May 7 07:37:09 2010] 31154 1103673168 trace message: SUNIXDaemon::init: redirecting stdio to /dev/null

    [Fri May 7 07:37:09 2010] 31154 1103673168 (sidaemon.cpp:209): trace message: installing fg terminiation handler

    [Fri May 7 07:37:09 2010] 31154 1103673168 (sidaemon.cpp:220): trace message: installing abnormal sys handler

    [Fri May 7 07:37:09 2010] 31154 1103673168 (sidaemon.cpp:506): trace message: SUNIXDaemon::init: finished

    [Fri May 7 07:37:09 2010] 31154 1103673168 Log: level=0 cat=14 msg=35101 p=The root server reported an error Unknown.

    [Fri May 7 07:37:09 2010] 31154 1103673168 trace message: SIServerController:run: Fail to initialize or uninitialize. Reason is The root server reported an error Un

    known.:

    [Fri May 7 07:37:09 2010] 31154 1103673168 trace message: CsContainer::uninitialize

    [Fri May 7 07:37:09 2010] 31154 1103673168 trace message: TransientObjectMonitor stopMonitor()...

    [Fri May 7 07:37:09 2010] 31154 1103673168 Log: level=0 cat=14 msg=35101 p=The root server reported an error Internal Error. (Reason: Unknown exception caught in ser

    ver).

    [Fri May 7 07:37:09 2010] 31154 1103673168 assert failure: (siserver.cpp:953). (false : SIServerController::run: Unknown exception caught in server's uninitializatio

    n function

    ).

    [Fri May 7 07:37:09 2010] 31154 1103673168 Log: level=3 cat=1 msg=35100 p=ConnectionServer stopped

    Any idea ?

    Thanks.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 07, 2010 at 01:26 PM

    Hi

    I remember facing the similar issues long back on XIR2 at the customer site. I was a BO consultant at that time, I am now working on Cognos.

    The culprit was a configuration file called cs.cfg. I replaced it with same file from another BO setup and it worked. I was working on a production issue at that time. This troubled me for few days and finally I was able to track down to this file. after replacing this it worked perfectly.

    I don't remember the exact file location.

    Cheers

    Loki

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 07, 2010 at 01:26 PM

    Hi

    I remember facing the similar issues long back on XIR2 at the customer site. I was a BO consultant at that time, I am now working on Cognos.

    The culprit was a configuration file called cs.cfg. I replaced it with same file from another BO setup and it worked. I was working on a production issue at that time. This troubled me for few days and finally I was able to track down to this file. after replacing this it worked perfectly.

    I don't remember the exact file location.

    Cheers

    Loki

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 07, 2010 at 01:26 PM

    Hi

    I remember facing the similar issues long back on XIR2 at the customer site. I was a BO consultant at that time, I am now working on Cognos.

    The culprit was a configuration file called cs.cfg. I replaced it with same file from another BO setup and it worked. I was working on a production issue at that time. This troubled me for few days and finally I was able to track down to this file. after replacing this it worked perfectly.

    I don't remember the exact file location.

    Cheers

    Loki

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 07, 2010 at 01:27 PM

    Hi

    I remember facing the similar issues long back on XIR2 at the customer site. I was a BO consultant at that time, I am now working on Cognos.

    The culprit was a configuration file called cs.cfg. I replaced it with same file from another BO setup and it worked. I was working on a production issue at that time. This troubled me for few days and finally I was able to track down to this file. after replacing this it worked perfectly.

    I don't remember the exact file location.

    Cheers

    Loki

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 07, 2010 at 01:27 PM

    Hi

    I remember facing the similar issues long back on XIR2 at the customer site. I was a BO consultant at that time, I am now working on Cognos.

    The culprit was a configuration file called cs.cfg. I replaced it with same file from another BO setup and it worked. I was working on a production issue at that time. This troubled me for few days and finally I was able to track down to this file. after replacing this it worked perfectly.

    I don't remember the exact file location.

    Cheers

    Loki

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.