Skip to Content
0
Former Member
Jan 27, 2010 at 11:26 PM

Need help with "Failed to load database information."

23 Views

Greetings all,

Using VS 2005

CR XI R2 sp6

Code is in ASP.net with VB.net code behind.

Using merge module for sp6 and .msi file to install on IIS server.

Dev box is XP service pack 3

IIS Server OS is Server 2003 R2 standard edition Service Pack 2

Reports run fine if they are using out MS SQL server. Doesn't matter if I run the report localhost at the IIS box or out of IE 7 on my development box. Any report that gets data from our Oracle DB gives the following error:

Failed to load database information. Error in File C:\WINDOWS\TEMP\Arrivals By Date {E4D4AF52-E6B4-4C22-89E9-2FE809C23F8E}.rpt: Failed to load database information.

I have installed CR dev environment on the IIS box to try the reports directly and they work in the CR XI dev environment.

IIS box is upgraded to CR XI R2 sp6.

TNSNAME file is in place and ping tested.

Oracle drivers are installed and tested.

Using the following code to pass user name and password to Oracle.

rpt.DataSourceConnections(0).SetLogon("Test", "TestPass")

It appears to be passing parameters and prompts for the non passed parameters. It seems to blow up ass it goes to get the data for the report.

Merge module I am using is marked CrystalReports11_5_NET_2005.msm, size: 81872. I downloaded it the other day from the download spot here.

I have read all the posts and docs I can find on it and nothing I have found has worked. Any ideas?

Thanks,

Dan...

Edited by: Dan Pearce on Jan 29, 2010 12:10 AM