Skip to Content
0

Problem setting up HCP Cloud Foundry Services

Nov 25, 2016 at 12:25 AM

617

avatar image

Hello

I am trying to follow an exercise from TechEd where "HCP, Starter Edition for Cloud Foundry Services (Beta)" is utilised.

I followed the instructions up to the point where I subscribed to the service on my YaaS account. At the configuration screen I can see the organisation name and manager name already defaulted. I left the default space value, i.e. "dev" and hit the Create button. A success message was displayed but the form does not show the organisation name and manager details and the status says "Trial period: IN PROCESS". (Screenshot below, comparing to the result in https://github.com/SAP/cloud-cf-casino/tree/master/exercises/exercise03 ).

When I try "Manage HCP Application" button at the bottom right, it takes me to ~https://hcp-cockpit.cfapps.us10.hana.ondemand.com and when I log in it says "You are currently not assigned to a Cloud Foundry organization at this location.". When I hit the Subscribe button it takes me to Yaas Market and there it says I already subscribed.

It seems my Yaas API is pointing to an EU endpoint where as the HCP Cloud Foundry Cockpit takes me to US East (Beta). With a simplistic assumption that this might be the problem, I changed the above URL to replace "us10" with "eu10". I was taken to the login screen but it didn't help as the login stalled and when I tried re-activation, something went wrong and now when I try to log in it says I need to activate; hence in a dead end.

I guess there are not many experts in this area but any suggestions to sort the issue are welcome.

Thanks...

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

6 Answers

Best Answer
Jose Nunes
Jan 04, 2017 at 11:45 AM
1

Hello Serdar,

I'm facing the same issue. I've tried recreating the organization and project but no luck, the Service Status still stalled on IN PROCESS.

I found this thread on hybris expert QA: https://experts.hybris.com/questions/65479/not-able-to-configure-hcp-with-my-organization-aft.html where they stated that there was an issue with the service, but it is still happening.

EDIT: after deleting the organization and project and starting over, it worked.

Regards,
JN

Share
10 |10000 characters needed characters left characters exceeded
Serdar Simsekler Feb 07, 2017 at 02:51 PM
0

Hello Jose

Thanks for your response. I was actually exhausted trying different combination of changes to make it work and parked it for a while until I realized I got a message saying there is an answer from you.

Actually, when I first posted my question, it was after I had tried creating new organization and project after deleting the existing ones. And it hadn't worked.

Your response made me try again. So, here is what I followed as any of the steps this time might include the magic resolving the issue:

1. I deleted the existing organization and project from my YaaS account and logged out.

2. I logged in to my trial HCP account and navigated to Services --> HCP, Starter Edition for Cloud Foundry Services - Overview

3. I clicked on Documentation. In the documentation, I navigated to Getting Started --> Sign Up

4. I clicked the direct link for the Yaas service where it says "Alternatively, you can access the package directly at HCP, Starter Edition for Cloud Foundry Services (Beta)."

5. YaaS asked me to log in. After logging in, as there was no existing organization, I clicked on the link provided to create an organization.

6. I followed to create a new project. On the project page I clicked Subscribe.

7. In the coming page, I chose the service "HCP, Starter Edition for Cloud Foundry Services (Beta)".

8. I followed the rest of instructions to configure and create the subscription.

Maybe the above does not make much difference as the issue might have been resolved after they put the fix they mention in the link you provided.

All said, thanks for your effort in responding my question.

Kind Regards

*--Serdar

Share
10 |10000 characters needed characters left characters exceeded
Thorsten Kampp Feb 14, 2017 at 07:13 PM
0

Hello,
I had the same issue, but neither removing org & projects nor the steps mentioned above did really help me.
In the YaaS Builder I had to go into the corresponding project -> Adminstration -> Customization. The region was empty, so I selected “EU”. After saving this, I could create an organization and access the administration interface within the SAP Cloud Platform.
All the best,
Thorsten

Share
10 |10000 characters needed characters left characters exceeded
Nils Frkal Feb 16, 2017 at 07:40 AM
0

All,

I have the same problem. Even with following exactly all steps described by Serdar and then setting the region to EU or US as mentioned by Thorsten does not work for me. I still do not have an organization assigend (cf orgs -> No orgs found). @Thorsten: In which region is your HCP Trial Account? Did you use the api https://api.cf.us10.hana.ondemand.com to connect, but still used "EU" as your customization setting?

When I look at the screenshot Jadwiga has provided on https://experts.hybris.com/questions/59331/no-orgs-on-hcp-cloud-foundry.html there seems to be a "Create" button on the top right corner. I can only see this button if no project has been set up and when I click on the SAP HANA Cloud Platform item the organization field is empty and status remains in "Trial period: IN PROCESS".

Any other idea if I am missing a step?

Thank you very much.

Best, Nils

Share
10 |10000 characters needed characters left characters exceeded
Thorsten Kampp Feb 21, 2017 at 09:27 AM
0

Hi Nils,

The region of my HCP Trial Account is Europe. Curiously I am still using the URLhttps://api.cf.us10.hana.ondemand.com to connect. I can only assume, that there needs to be a mapping between my HCP Trial Account and my YaaS account (therefore the setting to EU) – and the HCP w/ CloudFoundry is a dedicated instance only available in US right now. But this is just a guess.

Before I selected a region I also had “In Progress”. After I finally could successfully create the organization the dialog in the builder looked like the attached screenshot. Using “Manage HCP Applications” you can now jump to the hcp-cockpit to manage spaces & applications.

All the best,

Thorsten


Share
10 |10000 characters needed characters left characters exceeded
Matias De la Rosa Feb 22, 2017 at 08:28 PM
0

Hi Serdar Simsekler,

I found this video really helpful to start.

https://www.youtube.com/watch?v=PDnjQBgh24k

Cheers!

Share
10 |10000 characters needed characters left characters exceeded