Skip to Content
0

SAP C4C and S4HANA Error Replication CL_BUPA_MDG_REPLICATE_BUPA

Nov 24, 2016 at 10:51 PM

801

avatar image
Former Member

Hi Expertes,

We are integrating SAP S4HANA 1511, SAP PO and C4C. I am getting an error when I am trying to execute initial load in the web service monitor payload:

Exception: Error in message header mapping; agent class is CL_BUPA_MDG_REPLICATE_BUPA

S4HANA has only two submenus Replicate Materials (BD10) and Business Partner and Relationship (DRFOUT). DRFOUT transaction has filters and you can manually select the information you want to replicate. I have selected only the organizational structure but it seems that always is sending all information (filters with asterisk).

How can I replicate only the organizational structure from S4HANA to C4C??

Could the error be related for mapping definition??

The best practice guide word document "Basic Integration Set up using Process Integration system -1EJ", the Organizational Structure is manually created.

Best Regards

David Cortes

error1.jpg

error2.jpg

error1.jpg (356.5 kB)
error2.jpg (308.0 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Sharad Dixit
Nov 25, 2016 at 07:35 PM
0

Hi David,

Above exception basically, comes when there is inconsistency in the payload within message header. In C4C inbound payload , within message header, you will have fields like <SenderParty> and <RecipientParty>. If it is an inbound service interface in C4C, check if “SenderParty = ERP system” and “RecipientParty = My System (C4C)”.

The Recipient Party in payload should be same as My System in communication arrangement in C4C, if it is not the case, please correct the partner profile in ERP so that payload will send RecipientParty = C4C My System ID.

Regards
Sharad

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Wowwww,

Thank you so much Sharad... Once again you were totally right. The problem solved changing the SenderBusinessSystemID as same as the Business System ID in the System Communication.

YOU ROCK!!!

Best Regards my friend.

David Cortes

1
avatar image
Former Member Mar 03, 2017 at 07:33 PM
0

Hi All,

Im currently facing the same issue on S/4 1610. Do you have any solution ? What seems to be strange is that <SENDER PARTY> is empty ?

How may I correct the sender party ?

Thanks,

Pierre

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Christophe,

Are you using custom mapping in middleware ?

Regards
sharad

0

Hello!

I'm facing the same issue on S/4 Hana 1610 integration with C4C 1802.

Something rare with the <SENDER PARTY>

Did you find guys the solution to your problem?

thanks in advanced

Here is my post

https://answers.sap.com/questions/476897/business-partner-replication-from-s4-hana-to-c4c-e.html

0