Skip to Content
0

Fiori - SAP GUI for HTML Issue

Nov 24, 2016 at 08:47 PM

81

avatar image

Hello everybody.

I'm facing a problem when i'm lauching an app using SAP GUI for HTML.

A new window appears asking for the credentials again and the conection type is HTTP instead of HTTPS.

I have two RFC configured. First one HTTP(8000) and second HTTPS (8001). Noticed that the RFC that has been used is HTTP and not HTTPS.

Following the documentation, did the mapping:

https://help.sap.com/saphelp_nw75/helpdata/en/c2/4f901136e74a9bb8364a001a146642/content.htm

The application that i'm trying to use:

So, i have two questions:

1 - I have a security problem. I'd like to use HTTPS connection instead of HTTP.
For my applications using Web Dynpro, the mapping works very well. The RFC that has been called is HTTPS, FIORI_BE_HTTPS.

What's the problem? Why SAP GUI for HTML is not using RFC FIORI_BE_HTTPS?
Is it a limitation of mapping?

2 - I'd like to do login once, using SSO. Is it possible? What do i need?

Any help will be appreciated.

Best regards,
Guilherme

1.png (6.8 kB)
2.png (19.9 kB)
3.png (32.6 kB)
4.png (45.1 kB)
6.png (11.4 kB)
7.png (78.7 kB)
10 |10000 characters needed characters left characters exceeded

Are you saying that SSO from Fiori works for WebDynpro, but not for WebGUI?

0
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Guilherme Lahr Nov 25, 2016 at 12:17 PM
0

Actually SSO doesn't work for both of them.

In both cases i need to login a second time. SSO will solve this problem?

The difference is that for WebGUI is using HTTP instead of HTTPS, like WebDynpro.

Share
10 |10000 characters needed characters left characters exceeded