Skip to Content
author's profile photo Former Member
Former Member

No scenario for MAM for user

Hello everybody,

I already saw some of you having problem with users which get a message like "No scenarion for user" in MAM.

I have the same problem, but only for 1 user and only when he creates a new notification.

We have a SyncBO ZMAMFR_010 which is derived from MAM25_010 for our French users.

This user is able to work normally with his MAM and gets all orders and notifications downloaded on his MAM. He is also able to upload changes to his orders, time confirmations and so on.

But he can not create a new notification as he gets a syncrhonization error on the notification.

All our users in France use the same scenario and we don't use user-specific settings. So all users are the same and have also the same access rights.

The customizing is done in our Development system and transported to our quality and production system. The strange thing is that this user can create the notification in the quality system, but not on the production system. So I think something is corrupt in the production system.

Does anybody of you know what can be wrong?

thanks in advance.

Erik Meel

MAM Project Engineer

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jan 23, 2010 at 09:48 AM

    Hi,

    most likely you missed the import parameter - and so this is empty.

    Well, in short word: if you check the MAM30_011_create module in se37 in backend, you will notice that it requests a username as import parameter. This is the user to create this notification.

    Well, if you now go to the middleware and check for example MAM30_010 or MAM30_005 syncbo in SBUILDER, you will see that there is a username send across to the backend. This is done by selecting ENVIRONMENT->DEFAULT VALUES from the top menu and in there you should see something like:

    VALUE ID = USER_ID

    VALUE = ME-SYNC_USER

    DESCRIPTION= USERNAME

    Well, just make sure as well, that the ME-SYNC_USER is not written in 'xxxx', cause this will transfair the text (ME-SYNC_USER) and not its value, the username (OLIVER).

    This should help.

    Regards,

    Oliver

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      okay, so just lets clarify 3 things -

      1.) in SPRO this user is defined the same way as all others?

      2.) you have same setup and same logon procedure as all other users?

      3.) running the relevant function module that fails in your case in backend for this user has no issue?

      Well, I do understand that WebEx is only possible for SAP OSS people, but WEBEX is just on your desktop and you whatch everything I do, cause you are sitting at your desk and if you stop it - then you stop it. So it is not an anonymous service. All you need is an open Browser and Port 80, there is no open system necessary.

      Regards,

      Oliver

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.