Skip to Content

Exception cx_sadl_view_element_undefined

Hello,

I have enhanced CDS view with few fields . Later , Application is giving the following exception -

cx_sadl_view_element_undefined .At UI level , I am seeing the following message

is not mapped to a SADL data source and must be handled programmatically .

Because of this exception , layout is getting disturbed . do you know how to resolve this error.

Andre Fischer .. can you help on this please

Do I need to enhance BOPF?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Nov 23, 2018 at 04:20 PM

    From the amount of information we have here it is hard to judge.

    You would have to provide more details how you have enhanced the CDS view and which CDS view.

    Regards,

    Andre

    Add comment
    10|10000 characters needed characters exceeded

    • Hello,

      Andre Fischer ,Thanks for the reply ...

      I have enhanced standard CDS Views , to show standard fields in Standard Fiori apps.

      These standard fields are not given by SAP . So I tried to enhance the underlying Consumption CDS - C_ContractMaintainItem view using different alias names assuiming if in future if SAP adds these fields , it will not be a problem .As I have extended the CDS Views,I am able to add these standard fields in UI using In App Extensibility Technique.

      Filip Nespor , Thanks for the reply ... Yes I knew this app . But as i wanted to add standard fields to standard app , I tried to enhance CDS view .

      Please help

  • Nov 23, 2018 at 04:20 PM

    Hi Pawan,

    Did you have a look if "Custom Fields and Logic" app is not available in your system? If so, adding fields via this app would be much easier for you.

    More information about that app can be found here: https://help.sap.com/viewer/9a281eac983f4f688d0deedc96b3c61c/1709%20000/en-US/57909455bf7c4fdd8bcf48d76c1eae33.html

    Regards,

    Filip

    Add comment
    10|10000 characters needed characters exceeded

    • Hello Filip Nespor ,

      I just wanted to highlight one thing regarding this custom fields and logic app. If suppose, i create a custom field and tried to publish it, if somehow, if the publishing fails, then , i am not getting discard changes button enabled. It is disabled and the only way out is to delete the field and re create it again . But I think, this seems to be a bug for me if not an authorization issue.

      Do you have an idea on that..?Please help

  • May 06 at 04:14 PM

    Pawan Kalyan

    Did you ever solve this issue? I also enhanced C_ContractMaintainItem with an association to another CDS view containing some read-only fields, but receive the exact same error.

    Any update would be much appreciated!

    Thanks,
    Jan

    Add comment
    10|10000 characters needed characters exceeded

    • Solution: Do not extend the underlying I_PurchaseContractItemWD, but C_ContractMaintainItem directly:

      @AbapCatalog.sqlViewAppendName: 'ZXCPURCTI'
      
      
      extend view C_ContractMaintainItem with Z_X_ContractMaintainItem

      association [1..1] to Z_PurchaseRequisition as _PurchaseRequisition on $projection.purchasecontract = _PurchaseRequisition.PurchaseContract
      and $projection.purchasecontractitem = _PurchaseRequisition.PurchaseContractItem

      {
      @UI: {lineItem : [{position: 100, importance: #LOW} ],
      fieldGroup: {qualifier: 'Material', position: 100, importance: #LOW}}
      @ObjectModel.readOnly: true
      _PurchaseRequisition.CustomField }