Skip to Content
0

After creating Excise Invoice in J1IIN, the BED rate is not getting updated in Table J_1IEXCDTL

Nov 24, 2016 at 02:22 PM

166

avatar image
Former Member

Dear Experts,

After TAXINN migration, I had an issue that EXBAS field and BEDRATE field not getting updated in Table J_1IEXCDTL after creating Excise Invoice in J1IIN. So I included a JASS condition (statistical) in SD pricing procedure and implemented the User Exit - J_1I7_USEREXIT_CALC_EXC_BASE. Now the EXBAS field value is updated correctly in Table J_1IEXCDTL. However, the BEDRATE value is still not updated. Please advise me why still the BEDRATE (BED percentage) value is not in Table J_1IEXCDTL.

JEX2 is the BED condition used

ZTAXIN is the Tax procedure used

Note: Also we had implemented J_1I7_USEREXIT_DUTY_IN_EXPORT with Suppress_Calculation = 'X'. which works fine and BED value is updating correctly in J1IIN for USD.

Please refer the below screen shot for reference.

Pricing Procedure:

Tax Default Informations

Default Condition types

Conditions Triggered in Invoice:

Please advise me in this issue.

Regards,

Ramkumar

sw4zh.png (31.1 kB)
7ncjf.png (9.1 kB)
d5zzk.png (10.4 kB)
lidoi.png (39.4 kB)
hb5y4.png (12.1 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

G Lakshmipathi
Nov 24, 2016 at 03:06 PM
0

I changed the Primary tag which should be used for all CIN related queries. Coming to your query, you have not indicated whether both are flowing in billing document. Try removing the statistical check box for JASS and retry. Also have a look at OSS note 1042035

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Dear Sir,

Thanks for the reply.

Yes, both JASS and JEX2 condition are flowing in the invoice. Please refer screen shot given in my query.

I had checked the note 1042035, as per the note we already implemented the User Exit - J_1I7_USEREXIT_CALC_EXC_BASE, now the EXBAS field is updated correctly in table J_1IEXCDTL.

However, the BEDRATE (BED percentage) value is still not updated in table J_1IEXCDTL

. Please advise me why still the BEDRATE (BED percentage) value is not in Table J_1IEXCDTL.

Regards,

Ramkumar

0
G Lakshmipathi
Nov 25, 2016 at 07:35 AM
0

Did you try removing the statistical check box for JASS and tested, as I suggested earlier? I feel, this should solve your issue.

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Dear Sir,

Thanks for spending time for me.

Please note that it is not the issue with JASS condition type as Statistical.

I found the solution:

In TAXINJ, the JMOD % is getting passed from J1ID. So default condition types is maintained as below in TAXINJ.

The same thing we usually copy from TAXINJ to ZTAXIN. This is the same mistake I did.

Whereas If you see in my Invoice condition screen shot, the JMOD is where the BED % 12.5 is passed and JEX2 will be passed as 100% through condition record (After TAXINN migration). So we need to change the settings as in below screen shot. Now issue solved.

regards,

Ramkumar Lalaram

ju9zd.png (8.9 kB)
lfapt.png (9.0 kB)
1
Phanikumar Valiveti Nov 26, 2016 at 04:17 AM
0

Dear Ramkumar

We appreciate you on updating the forum with answer find by your own which is missing in most of the cases.

Thank you for this.

Note: Your screen shots are not openable here..can you please reassign.

Phanikumar

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Nov 28, 2016 at 06:41 AM
0

Hi Phanikumar,

FYI.

Regards,

Ramkumar L


cyg4i.png (8.9 kB)
dqykg.png (8.9 kB)
Share
10 |10000 characters needed characters left characters exceeded