Skip to Content

BI 4.2 SP5 - Web Assistant active

Hi,

As per note 2723208, Fiorified BI Launchpad defaults with web assistant active. Is there a way to deactivate Web Assistant with a config setting?

Thanks

Sonni

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    Nov 22, 2018 at 02:02 PM

    There is another solution for enabling and disabling the "Web Assistant" button. (add helpButton.setEnabled(false); which permanently disables the button)

    I think we talked about what's mentioned in Note, and I've noticed that after logging in, the "Web Assistant" is active by default and must be disabled by clicking on it to continue working with BILaunchpad.

    The solution was to disable it by default, and the user can work with BI directly after logging in. At the same time, the user can reactivate the "Web Assistant" and use it.

    So, the "Web Assistant" is not completely disabled.

    just _XRayAdapter.toggle(); was not in the right place in the js (unnecessary).


    webassistant.jpg (22.9 kB)
    Add comment
    10|10000 characters needed characters exceeded

    • also I think that it was intended to show the user "what's new" directly after logging in and forget to give the user the option to disable it when needed

  • Nov 22, 2018 at 01:25 PM

    No options to disable the button.

    But you can stop sending network calls to Web assistant server by commenting below lines from web.xml:

    Location : C:\Program Files (x86)\SAP BusinessObjects\tomcat\webapps\BOE\WEB-INF\eclipse\plugins\webpath.FioriBI\web\WEB-INF\web.xml

       <servlet>
            <servlet-name>XRayProxyCP</servlet-name>
            <servlet-class>org.mitre.dsmiley.httpproxy.ProxyServlet</servlet-class>
            <init-param>
                <param-name>targetUri</param-name>
                <param-value>https://cp.hana.ondemand.com/dps</param-value>
            </init-param>
            <init-param>
                <param-name>log</param-name>
                <param-value>false</param-value>
            </init-param>
        </servlet>
        <servlet-mapping>
            <servlet-name>XRayProxyCP</servlet-name>
            <url-pattern>/sap/dfa/help/*</url-pattern>
        </servlet-mapping>
        
        <servlet>
            <servlet-name>XRayProxyResources</servlet-name>
            <servlet-class>org.mitre.dsmiley.httpproxy.ProxyServlet</servlet-class>
            <init-param>
                <param-name>targetUri</param-name>
                <param-value>https://xray.hana.ondemand.com/xRayControls/resources/sap/dfa/help</param-value>
            </init-param>
            <init-param>
                <param-name>log</param-name>
                <param-value>false</param-value>
            </init-param>
        </servlet>
        <servlet-mapping>
            <servlet-name>XRayProxyResources</servlet-name>
            <url-pattern>/resources/sap/dfa/help/*</url-pattern>
        </servlet-mapping>
    
    
    Add comment
    10|10000 characters needed characters exceeded

  • Nov 22, 2018 at 01:33 PM

    According to the Note is still under investigation.

    The user must click the "Web Assistant" button to deactivate it after logging in.

    and there is no configuration to disable it by default.

    ....

    It's a bug, and if you want to fix it with yourself, make only a small change in the js code in the file

    .......\webapps\BOE\WEB-INF\eclipse\plugins\webpath.FioriBI\web\com\sap\fioribi\modules\homepage\HomepageView.view.js

    edit the file and search for _XRayAdapter.toggle(); and comment it ----> /*_XRayAdapter.toggle();*/

    and then save and copy the file to the same directory tree under "....\work\Catalina\localhost\" ( ...\webapps\...... ----> ...\work\Catalina\localhost\....)

    Then log in with the user and the "Web Assistant" is disabled by default.

    The user can click again to activate it.

    ..

    As I always say, be aware of SAP support if you have changed the code with yourself.

    do it on your RISK. "Do not do it if you do not know what you are doing"

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 22, 2018 at 01:45 PM

    You can achieve it by changing the code as Ayman suggested (https://answers.sap.com/answers/694010/view.html).

    Even in this case also button wont be disabled.

    This change also stop network calls to web assistant only.

    Add comment
    10|10000 characters needed characters exceeded