Skip to Content

dump :Field symbol has not yet been assigned.

Hi ,

i have this piece of code given below . the fieldcatalog is of structure of <fs_tab>.

call function 'REUSE_ALV_GRID_DISPLAY'
       exporting
            i_callback_program      = gd_repid
*            i_callback_top_of_page   = 'TOP-OF-PAGE'  "see FORM
            is_layout               = gd_layout
            it_fieldcat             = fieldcatalog[]
            it_events               = gt_events
            i_save                  = 'X'
       tables
            t_outtab                = <fs_tab>
       exceptions
            program_error           = 1
            others                  = 2.

i gets a dump

Field symbol has not yet been assigned.

You attempted to access an unassigned field symbol

(data segment 10).

This error may occur if

- You address a typed field symbol before it has been set with

ASSIGN

- You address a field symbol that pointed to the line of an

internal table that was deleted

Plz help to resolve this problem .

Regards .

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

5 Answers

  • Best Answer
    Posted on Jan 19, 2010 at 12:23 PM

    Hi,

    you have a mismatch field between fieldcatalog and t)outtab.

    Does your <fs_tab> have explicit type declaration?

    field-symbols <fs_tab> type table of ys_table.

    If you use type any table can be the problem.

    But check your fieldcatalo, the problem should be there...

    Frisoni

    Add comment
    10|10000 characters needed characters exceeded

    • Hi,

      Just check the contents of the internal table which you are passing to the field-catalog.

      Do they have the same fieldnames as the internal table which contains the data which you want to display in ur ALV.

      Regards,

      Ankur Parab

  • Posted on Jan 19, 2010 at 12:23 PM

    Hi,

    This dump usually appears due to the problem in fieldcatalog.

    Check the names of the field in the fieldcatalog.

    They should be same as the fieldname of the internal table and in capital.

    Usually it is the fieldcatalog which is the problem.

    Also one more thing; for i_callback_top_of_page = 'TOP-OF-PAGE' you have to pass the subroutine name and not the event name.

    Regards,

    Ankur Parab

    Add comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 19, 2010 at 12:28 PM

    can u send how u have code the build catalog in the report.

    Mostly the error will be there.....

    Add comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 19, 2010 at 02:05 PM

    hi thanks all for reply the problem is solved .

    Add comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 19, 2010 at 02:06 PM

    Thanks

    Add comment
    10|10000 characters needed characters exceeded