Skip to Content
avatar image
Former Member

Kernel 640 EX2 patch level 315

Dear all,

Because of the problem related to the sap note 1422843 'Wrong deletion date in spool request', i was updating the systems of my client to the required version 315.

For the non ex versions i had no problem, but when i tryed to use the EX2 version for one SRM4.0 system with oracle 10 i had a problem with the dispwork executable; with the command dispwork -v i get the message "the system cannot execute the specified program".

This problem seams similar to the one explained in the note 684106, but i had already installed the vcredist_IA64.exe dlls because i had that problem with a previous release of the kernel (304).

So my situation actually is that i can execute the disp+work -v command with the 304 kernel EX2 but not with the version 315.

My questions are:

1) is there a workaround to solve the issue of the 315 EX2 version?

2) is there a real difference between the EX2 version and the normal 640 version? (i didn't find any difference in the pam and no difference in these notes 1106096, 1058988).

3) the disp+work -v on the kernel 640 not EX2 patchlevel 315 specify that it can be used with oracle 10, so can i use this instead of the ex2 version?

My operative system is a window 2003 enterprise ia64.

Thanks and regards

Federico

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

10 Answers

  • Best Answer
    avatar image
    Former Member
    Jan 14, 2010 at 09:45 AM

    Hi Markus,

    i thought the same, but i downloaded it again and i did a check of the size of the DW package and it was the right one (dw_315-10004707.sar size about 95 mb).

    Thanks

    Federico

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 12, 2010 at 02:56 PM

    > 1) is there a workaround to solve the issue of the 315 EX2 version?

    I'd check the event log for further information what is missing.

    > 2) is there a real difference between the EX2 version and the normal 640 version? (i didn't find any difference in the pam and no difference in these notes 1106096, 1058988).

    The 640_EX2 kernels use the Oracle 10g instantclient where as the normal 640 version uses the 9.2 client.

    > 3) the disp+work -v on the kernel 640 not EX2 patchlevel 315 specify that it can be used with oracle 10, so can i use this instead of the ex2 version?

    See above.

    Markus

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Eric Brunelle

      Hi Eric,

      We had the same problem last friday with the last R3trans.exe.

      The executable was corrupted and it screwed up our EHP4 upgrade. It took us hours to find out and to reverse to the previous R3trans executable which worked fine.

      So much with the idea that it is safer to use last releases of tp.exe and R3trans.exe !

      We downloaded the file several times so we think that it is corrupted on the SAP server...

      We need SAP to manage the download servers more seriously.

      Regards,

      Olivier

  • Jan 12, 2010 at 01:10 PM

    I have the exact same problem with kernel 7.01 for Windows 2003 64-bit (AMD64) patch 75.

    You better wait for the next kernel patch release.

    Add comment
    10|10000 characters needed characters exceeded

    • kernel 7.01 for Windows 2003 64-bit (AMD64) patch 76 is now released. maybe other platforms also have a new kernel available.

      About the error messag:

      "the system cannot execute the specified program".

      apply SAP Note 1375494 - SAP system does not start after applying SAP kernel patch

      it should fix this issue.

      Close this message if problem is resolved.

  • avatar image
    Former Member
    Jan 13, 2010 at 08:57 AM

    Thanks all,

    by checking the server of my client i saw that on the srm 4.0 the 640 normal kernel release 315 is working fine, but this server have an oracle 10 so i must assume that the client 9 is still installed in it after per upgrade to the release 10?

    How can i chek it?

    Can someone explain me why in the upgrade guide to oracle 10 and in the note to create a kernel ex2 dvd for installation is required to use the brtools 700, but on the oss where i downloaded the kernel update for the ex2 there are the brtools for oracle 9.2? isn't it a non sense?

    thanks and regards

    Federico

    Add comment
    10|10000 characters needed characters exceeded

    • about brtools in the EX2 kernel, yes, this is strange, you will need to get it from another part. go in the netweaver 7.00 section for your Os/DB and use brtools made for Oracle 10g. Thjis is what I use to do when using a Oracle version newer than the one that was used originally with a kernel.

  • Jan 13, 2010 at 07:32 PM

    Hi,

    As Mr. Eric already wrote please apply Microsoft fix from this SAP note, this is a problem with Visual C++ version installed in some Windows 2003 servers. This is not a problem with the files downloaded from SAP swdc.

    SAP Note 1375494

    This will solve the problem to all having the same Windows message.

    Have a nice day

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 13, 2010 at 07:43 PM

    Thanks Eric,

    but as i wrote in my first post, i already applied the workaround described in the note, but nothing changed.

    The funny thing is that today i needed to upgrade the oracle of my client Cfolder instance to oracle 10 and i didn't need any ex2 kernel.

    The server is a 32 bit machine and is working with oracle 10 and the normal kernel 640 patchlevel 315, and because i uninstalled the oracle 920 folder i can assume that it is using the instant client or the oracle release 10.

    So i'am getting more confused.

    How can i definitively check if the system is using the instant client still if is not a EX2 version?

    Thanks and regards

    Federico

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 14, 2010 at 09:28 AM

    Hi Eric,

    as you can see by reading my first post in the part related to the vcredist_IA64.exe and the sap note 684106, you can see i already applied the solution proposed in sap note 1375494 (microsoft article MS09-035.mspx same as note 684106), but nothing changed.

    Unless Microsoft had release a new vcredist_IA64.exe in these 3/4 days, i think i cannot solve my problem with that note.

    Thanks

    Federico

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 14, 2010 at 10:19 AM

    Thanks Markus,

    i will search in the event log to find more informations, but as i said, i had already downloaded and installed the vcredist_IA64.exe, but no difference.

    If you did the same work with the same dw, i must assume i have another problem on my os.

    May be i can try on the quality server of my client.

    Thanks and regards

    Federico

    Edited by: Federico pancucci on Jan 14, 2010 6:17 PM

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 15, 2010 at 12:29 PM

    Thanks to everyone help,

    after Markus test we used the ex2 kernel on the quality system and seams work, so it must be an os issue on the development server.

    Thanks everyone for the help.

    Regards

    Federico Pancucci

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 02, 2010 at 09:10 AM

    Hi Fedrerico,

    Have you find out what was the cause which had happen in your development.

    Can you please share the information.

    BR,

    Eida

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Eida,

      unluckily i coulden't go to my client these days, so i still didn't tried to solve the problem, but i could see that sap did two change to the note 1422843 from when i opened this thread.

      The first one was to adding this sentence to the note "Attention: Do not use the 640_EXT kernel patch that is attached to this message. A new 640_EXT kernel is currently under development." so i thought i cold have the problem because of a kernel issue, the second change was made yesterday and i think they just deleted the sentence; so i was thinking to try to download the new kenel to see if my problem could be resolved.

      My only other idea was to uninstall and install again the microsoft dll, if possible.

      If the problem will be resolved i will post the solution.

      Regards

      Fede