Skip to Content
0

PI: SFTP - Error: Message could not be forwarded to the JCA adapter. Reason 4: Putting failed.

Nov 24, 2016 at 10:11 AM

719

avatar image

Hi Experts,

We are encountering the following error with our PI Configuration using SFTP protocol with PGP Encryption.

Exception caught by adapter framework: 4: Putting <filename> failed.

Message could not be forwarded to the JCA adapter. Reason 4: Putting <filename> failed.

Based on our testing the error happens when the file reaches around 100 kb which is not that big. We are able to send files to the SFTP server if the file is less than the 100 kb size mentioned.

We have tried/checked all the solutions in the internet:

ASMA configuration:

Module configuration:

Attached is the message log below, showing the PGP Encryption is okay, but when file is being written the error is being encountered:

We have tried the following solutions too but the issue still exists:

1. Set skipRemoteDirCheck to true

2. Removed ASMA settings and set a fixed filename

3. Re-imported the whole scenario from our Development

4. Removed PGP encryption

5. Cleared CPA Cache both Full and Delta

We also successfully transferred a 300 kb file manually using FileZilla to the Partner SFTP server.

Would be grateful for any solution! Thanks in advance!

Regards,

Allan

asma.jpg (19.1 kB)
module.jpg (84.7 kB)
log1.jpg (212.8 kB)
log2.jpg (100.0 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Allan Jason Mercado Nov 28, 2016 at 07:22 AM
0

It seems the problem is on the Partner side, our PI configuration can successfully send to another SFTP server but when sending to their SFTP server we are getting the error "Connection Reset by Peer" after some time.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Allan,

did you find a solution yet?

We got exactly the same problem. In our case it's the SuccessFactors SFTP-Server and it works with <1 KB, but not above.

regards,

Heiko

0
Raghuraman S Nov 24, 2016 at 10:38 AM
0

Hello Allan,

check if the note -1737547 helps.

Also check the length of the file,could be too long.

Share
10 |10000 characters needed characters left characters exceeded
Allan Jason Mercado Nov 25, 2016 at 02:50 AM
0

Hello Raghuraman,

Thanks for the reply. We have already tried the parameter skipRemoteDirCheck which is mentioned in note 1737547.

Not sure what you meant with the length of the file but the longest line we have in the file is 797 characters long but we were able to send a file this long before. If you're talking about the filename its only User.txt.pgp

Share
10 |10000 characters needed characters left characters exceeded