Skip to Content

SAP B1 Install: Problems to access Shared Folders from Windows Version 1803

Hi,

I am trying to install the Windows Components for SAP Business ONE / HANA on a Windows 10 (version 1803).

I had already successfully installed these components, but the there was some problem with the windows server and the server got reinstalled.

When I try to install the windows components I get to the screen where I a supposed to choose the components to install, but I cannot install them because another screen opens informing me that it cannot access the shared folders.

I checked on the server and it seems that shared folders are ok:

As the newer versions of windows 10 (since 1709?) don't support samba v1 per default, since it is a security risk. The Administrator's Handbook states:

Make sure that your Windows machine can connect to Samba protocol version 1. If you enforce using Samba protocol version 2 or higher on the Windows machine, you need to install your Linux components on SUSE 12.

It would have been nice to know what components to install on SLES 12. But I have already 4.6.14+ that is why I think it should support version 2 or newer.

Therefore I edited /etc/samba/smb.conf

[global]
.... other stuff
min protocol = SMB2
max protocol = SMB3
client min protocol = SMB2
client max protocol = SMB3

I am not sure whether this neccesary, because I read that per default if no version is specified version 3 or newer is assumed. But I am not sure whether this applies to SLES 12.

I restarted samba. Checked the validation on the server which showed that the shared folders are okay. But unfortunately I still get the same error.

Any advice appreciated.

Best regards

Nils Stritzel

errorp2.png (47.4 kB)
sharedfolders.png (17.3 kB)
Add comment
10|10000 characters needed characters exceeded

  • Ok, I think I got working. I change the smb.conf so that contained:

    [global]
    .... other stuff
    min protocol = NT1
    max protocol = NT1
    client min protocol = NT1
    client max protocol = NT1

    ..other stuff

    Not sure why this works. If somebody can enlighten me, I would be grateful.

3 Answers

  • Posted on Mar 11 at 04:47 PM

    In Windows 10, version 1709, Windows 10, version 1903, Windows Server, version 1709, Windows Server, version 1903, and later versions of Windows, the SMB2 client no longer allows the following actions:

    • Guest account access to a remote server
    • Fallback to the Guest account after invalid credentials are provided

    If you want to enable insecure guest access, you can configure the following Group Policy settings: Computer configuration\administrative templates\network\Lanman Workstation "Enable insecure guest logons"

    Note By enabling insecure guest logons, this setting reduces the security of Windows clients.

    https://support.microsoft.com/en-us/help/4046019/guest-access-in-smb2-disabled-by-default-in-windows-10-and-windows-ser

    Add comment
    10|10000 characters needed characters exceeded

  • Posted on May 26 at 06:40 AM

    Hi,

    I'm facing this issue also when upgrading SBO 10 PL 1 to PL 2

    it detect error accesing shared folder

    I'm upgrade from win server 2019, i've tried to run above suggested, but no work

    --- try to change this (no work)

    min protocol = NT1
    max protocol = NT1
    client min protocol = NT1
    client max protocol = NT1

    try microsoft web - no work

    https://support.microsoft.com/en-us/help/4046019/guest-access-in-smb2-disabled-by-default-in-windows-10-and-windows-ser

    please help how to solve this ?

    Thanks & Regards,

    Hendra

    Add comment
    10|10000 characters needed characters exceeded

  • Posted on May 26 at 10:22 PM

    Hi Nils,

    We currently saw that a few partners were facing the same issue. You can try to follow the steps of the SAP Note 2372080 - Unable to access samba shared folders to see if the issue is solved;

    There are two other notes that are link to the main note above:

    Hope the notes above can lead you to resolve the issue :)

    Thanks and regards,

    Lucca Mello

    Add comment
    10|10000 characters needed characters exceeded