Skip to Content
avatar image
Former Member

User credentials are asked again after clicking on Message Monitoring

Hi Experts,

We are facing a issue like the users are logging into the XI system using the https://hostname:port/rwb.

Further user is selecting the message monitoring tab, selecting the Adapter Engine <sid> and the clicked on Display button.After doing that it is displaying a pop-window asking the user credentials.The problem here is it is pointing to the different system as it should point to local system.

So please let us know what needs to be changed .

Thanks

Pradeep

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

10 Answers

  • avatar image
    Former Member
    Jan 04, 2010 at 08:56 AM

    Hi Pradeep,

    This is the usual behaviour of SAP PI system. When you select the Adapter Engine <SID> and click display, the credentials will be asked.

    So you need not change anything.

    How do you say its pointing to some other system ?

    Are credentials not working ?

    Cheers.....,

    Raghu

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Pradeep,

      I still do not understand how did you conclude that its pointing to SLD system.

      Enter the login credentials and tell me the result after that.

      Cheers.....,

      Raghu

  • avatar image
    Former Member
    Jan 04, 2010 at 04:53 PM

    Hi Pradeep,

    As per my experience, It's NOT suppose to prompt for credentials when you click on Display button for message monitoring.

    Yes, It prompts for credentials when you click on RWB once.

    message monitoring tab, selecting the Adapter Engine <sid> and the clicked on Display button.After doing that it is displaying a pop-window asking the user credentials

    But still, you may please check below entries in exchangeProfile

    Key: com.sap.aii.rwb.server.centralmonitoring.r3.r3name

    value: <You PI System SID>

    Key: com.sap.aii.rwb.server.centralmonitoring.name, com.sap.aii.rwb.server.centralmonitoring.r3.mshost

    value: <You PI system CI fully qualified name>

    2ndly, Please report if it's prompting for credentials for all users including OR only with particular user?

    If so you may please compare the role/authorization.

    Regards

    Sekhar

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 05, 2010 at 05:12 AM

    Hi Raghu,

    The Mentioned parameters are pointing to the local system....example in our case system id is XX2.

    Where as as i mentioned above when i select on Adapter engine and click on display....it asks for user credentials, which points to SLD system.

    The above problem is occurring for all users.

    Please help and do the needfull

    Thanks

    Pradeep

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Can you check bleow exchangeProfile entries and report out

      For AdapterFramework

      com.sap.aii.adapterframework.serviceuser.name - XIAFUSER (PIAFUSER)

      And it's posssoword entered correctly

      For RuntimeWorkbench

      com.sap.aii.rwb.serviceuser.name - XIRWBUSER (PIRWBUSER)

      And it's posssoword entered correctly

      Regards

      Sekhar

  • avatar image
    Former Member
    Jan 06, 2010 at 06:01 AM

    Hi,

    The parameters are correctly set and one more thing i observed is the parameter com.sap.aii.connect.rwb.name is given the local system host only.

    When clicked on component monitoring ,and then on adapter engine ,and clicked on settings ,further selecting exchange profile,verified the parameter com.sap.aii.connect.rwb.name which shows here the value as the host of the SLD System.

    I don't know from where the value it is taking .

    Please do the needfull.

    Thanks

    Pradeep

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member
      and then on adapter engine ,and clicked on settings ,further selecting exchange profile,verified the parameter com.sap.aii.connect.rwb.name which shows here the value as the host of the SLD System

      This is wrong.

      PI Hostname

      com.sap.aii.connect.directory.mshost

      com.sap.aii.connect.directory.name

      com.sap.aii.connect.integrationserver.name

      com.sap.aii.connect.integrationserver.r3.mshost

      com.sap.aii.connect.repository.mshost

      com.sap.aii.connect.repository.name

      com.sap.aii.connect.rwb.name

      com.sap.aii.connect.rwb.r3.mshost

      com.sap.aii.rwb.server.centralmonitoring.name

      com.sap.aii.rwb.server.centralmonitoring.r3.mshost

      SLD Hostname

      com.sap.aii.connect.landscape.name

      com.sap.aii.connect.cr.name

      Cross Verify all the above exchangeProfile entries and make sure that "com.sap.aii.connect.rwb.name" pointing to your PI hostname rather SLD hostname.

      Regards

      Sekhar

  • avatar image
    Former Member
    Jan 06, 2010 at 08:26 AM

    Hi

    The Parameters are set to local system host in the exchange profile of the system,but it shows that it is pointing to the sld system in the component monitoring tab as mentioned .The confusion here is from where it is picking the values of the sld system details.

    PI Hostname

    com.sap.aii.connect.directory.mshost

    com.sap.aii.connect.directory.name

    com.sap.aii.connect.integrationserver.name

    com.sap.aii.connect.integrationserver.r3.mshost

    com.sap.aii.connect.repository.mshost

    com.sap.aii.connect.repository.name

    com.sap.aii.connect.rwb.name

    com.sap.aii.connect.rwb.r3.mshost

    com.sap.aii.rwb.server.centralmonitoring.name

    com.sap.aii.rwb.server.centralmonitoring.r3.mshost

    The below parameters are pointing to SLD system .

    SLD Hostname

    com.sap.aii.connect.landscape.name

    com.sap.aii.connect.cr.name

    This is same for the entire landscape.

    Please do the needful.

    Regards

    Pradeep

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      If you are allowed to perform CPACache refresh using below URL

      http://<PI System name>:<http port>/CPACache/refresh?mode=full

      if this doesn't fix the issue then, execute this URL

      http://<PI System name>:<http port>/rwb/rtc?op=init

      Please report out if issue persists.

      Regards

      Sekhar

  • avatar image
    Former Member
    Jan 20, 2010 at 11:08 AM

    Hi Experts,

    Apologies for the late response.

    I tried the both options provided and still the problem exists.so please provide some inputs to solve the problem.

    Regards

    Pradeep

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 01, 2010 at 04:37 AM

    Issue is not solved.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 07, 2010 at 01:45 AM

    Hi Experts,

    The issue is resolved by changing the host name and the port number for the service SAPXI AF CPA Cache in visual administrator.

    Thanks all for the replies.

    Regards

    Pradeep.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 07, 2010 at 01:46 AM

    Now the issue is resolved

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 07, 2010 at 01:47 AM

    As the host name and port number is changed.

    It is solved.

    Add comment
    10|10000 characters needed characters exceeded