Skip to Content

DTP: data package extracts 11 records, while package size is 10 records.

Hello, guys.

I load master data into characteristic.

And for DTP I set package size = 10 records.

I dont use Semantic Groups, so I expect this limitation must work strictly.

However, when I load data via Simulation Request, I get this:

10 records for Data Package 1 = OK, but why it is 11 for Data Package 2?

Here is the first 26 records In PSA:

As you can see, for some reason, record 21 was also catched into the fish haul, why?

P.S. There are no start or end routines in transformation, and all fields of extractor are keys.

There is also a checkmark "Handle duplicate records", but I think it works later, and dosen't affect yet.

snap0486.png (46.6 kB)
snap0487.png (137.7 kB)
snap0489.png (214.4 kB)
snap0486.png (45.8 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Nov 15, 2018 at 01:22 PM

    Hey Aleksey,

    The processing mode of Master data is considered as "Serial Extraction and Processing of Source Package" by default.

    So in this case your data package will be dependent on Source package(which will be PSA).

    Thanks,

    Shadab

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 12, 2018 at 07:43 AM

    Hey Aleksey,

    You are correct ,it is the DTP setting which actually decides what should be the package size. I never mentioned the type of PSA affecting it.

    What i meant to say in above statement is about the processing mode of the Master data DTP which has the processing type as "Serial Extraction and Processing of Source Package".

    So whatever data package you mentioned in your DTP is generally overwritten by the package size of your PSA content data package size.

    DTP processing mode:

    PSA Content:

    DTP request:

    But if you are changing the Processing mode to Serial extraction and Immediate parallel processing it will consider the DTP's package size.

    Hope this helps.

    Regards,

    Shadab

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 13, 2018 at 02:50 PM

    Hello, Shadab!

    Well, in my case, I dont have such processing mode: "Serial Extraction and Processing of Source Package", instead I have:

    "Serially in the Background Process" (two other options is not relevant here)

    Also, If I use "Semantic Groups" this option is replaced with:

    "Serial Extraction, Immediate Parallel Processing".

    Now, lets check if option "Serially in the Background Process" is the analogue of

    "Serial Extraction and Processing of Source Package", and works the same way...

    In PSA I have about 300 000 records, devided in 3 DataPackages:

    And DTP settings are:

    And after starting it here is what I have:

    It is 43 packages, not 3 as your example. And this means:

    "Serially in the Background Process" != "Serial Extraction and Processing of Source Package"

    ---

    But If so, I dont understand, why our initial modes - are different by default?

    I can imagine some reasons for it, for example:

    1. My version of SAP BW components is 740, maybe yours is newer/older?

    2. Type of characteristic and its settings can affect DTP settings?

    3. Type of PSA and its settings affects DTP settings?

    Add comment
    10|10000 characters needed characters exceeded