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deactivation of BOM in CSV-Export

Former Member
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Hi

I've a problem while exporting a CSV-file in Crystal Report Server.

In every file Crystal generates a BOM (byte order mark) which looks like this: FF FE

Is there any possibility to deactivate the generation of this BOM?

thanks

Regards

Accepted Solutions (0)

Answers (1)

Answers (1)

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No option.

Can you explain why you need this?

Thank you

Don

Former Member
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Thanks for your answer.

We have to transfer the csv-file to a ibm host system, which cannot interpret this BOM.

We receive just some ugly hieroglyphics.

Regars

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Hello,

Update: I looked through our source code and the Kbase article again. I have not found the Adapt number used to add this registry key but it only shows up in Fix Pack 4.4 to 4.9. As of Service Pack 5 it no longer exists. Not sure why it was not migrated, typically all fixes that have been done are migrated into future Service Packs and Products.

So unfortunately to make this work your only option is to roll back to Service Pack 4 and Fix Pack 4.9. There are no new patches available or being create for XI R2 not so no option to get this key put back in. I am checking with the Product team to see if we can get it into CR 2008/CRS2008/BOE R3 V1.

Update, this key does exist again in CR 2008 Service Pack 2 and above.

_______________________________________________

I found a note to fix this, you have to add a registry key. You did not say what version so you'll have to use what ever version you have installed, this one is for CR XI R2:

1276013 - Crystal report exported in Comma Separated Values (CSV) format in Standard mode contains Hexadecimal Characters.

Symptom

When exporting the Crystal report in CSV format in Standard mode, the generated report contains hexadecimal characters.

Reproducing the Issue

Create a Crystal Report.

Select File->Export .

In the Format select Seperated Values(CSV) and click ok.

In the Seperated Values Export options select Standard mode.

The exported report if opened in any Hex Editor (e.g.UltraEdit) the report shows Hex characters athe beginning of the report.

Crystal Reports XI Release 2(CR XI R2)

Business Objects XI Release 2 Service Pack 3 (BOXI R2 SP3)

Cause

The hexadecimal characters seen in the exported report are the BOM (Byte Order Mark 0xEFBBBF) of the UTF-8 encoding. This BOM is added to help programs to determine the encoding of the Comma separated value (CSV) file.

Resolution

====================

WARNING:

The following resolution involves editing the registry. Using the Registry Editor incorrectly can cause serious problems that may require you to reinstall the Microsoft Windows operating system. Use the Registry Editor at your own risk. For information on how to edit the registry key, view the 'Changing Keys and Values' online Help topic in the Registry Editor (Regedit.exe). It is strongly recommended that you make a backup copy of the registry files before you edit the registry.

===================

Install FixPack 4.4

The registry key setting on the CR machine can control whether or not to have the BOM in the exported CSV file.

HKEY_CURRENT_USER\Software\Business ObjectsSuite 11.5\Crystal Reports\Export\CSV\IncludeUTF8BOM

It needs to be created if itu2019s not present.

If IncludeUTF8BOM is set to 0 the BOM is not included to the exported CSV file.

Note: CSV- will be a key and IncludeUTF8BOM will be a new DWORD

Thank you

Don

Edited by: Don Williams on Oct 7, 2010 8:04 AM

Former Member
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Hi Don

Thank you for your answer.

We're using Crystal Reports 11.5

I've have tried your solution, but it did not work. The BOM is still written in the top of the file, but I don't know why.

I had to create the keys Export & CSV and the DWORD, I even made a service-restart. But nothing helped.

I think, we will use a tool to remove the BOMs automaticly.

Thanks & regards

Former Member
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Hi !

If possible I'd like to reopen this issue. I'm having exactly the same problem and I tried to add the specified registry key, restarted the server, but I still get the BOM at the beginning of the file.

Is there another way to solve this ?

Thanks

Configuration : Crystal report server XI R2 Service Pack 5

Former Member
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You need to start a new thread. You can reference this one in it.