Skip to Content
avatar image
Former Member

Error in Receiver SOAP Adapter

Hi,

when using an https receiver adapter in PI 7.11 I get the error message:

Error when calling an adapter by using the communication channel CC_123082_UDFRECEIVER_SOAP_IN (Party: , Service: BC_123082_REMADV_D96A, Object ID: 2a895589066d30d4b2686e9d3a8d4c8d) XI AF API call failed. Module exception: 'SOAP Error'. Cause Exception: 'SOAP: response message contains an error XIAdapter/HTTP/ADAPTER.HTTP_EXCEPTION - HTTP 400 Bad Request'.

Please let me know how to resolce this problem.

regards,

meenakshi

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    Dec 31, 2009 at 07:44 AM

    Hi ,

    check this link

    /people/krishna.moorthyp/blog/2006/07/23/http-errors-in-xi

    Regards,

    Amit

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 01, 2010 at 08:33 AM

    Check receiver communication channel parameters like soap action and url. The request sent by XI is not properly understood by webservice. You may also check that the wsdl in PI is the latest version of webservice at receiver.

    Regards,

    Prateek

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 31, 2009 at 10:06 AM

    Hi,

    Just check with web service guys is the WSDL is correct.

    i think they need the payload with SOAP envelope check with them.

    HTTP 400 Bad request means the data reaching to webservice and the data or structure is improper.

    check from that side, ur connection is perfect.

    Thanks and Regards,

    Chinna

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 02, 2010 at 04:22 AM

    Hi ,

    check the url path or check the adapter properly deployed or not , may be huge messages are flowing once again check the ques

    are strucking and looking in to smq2

    regards,

    Surya

    Add comment
    10|10000 characters needed characters exceeded