Skip to Content
0
Former Member
Dec 29, 2009 at 07:06 AM

Java Engine not starting

116 Views

Dears,

We have installed PI 7.1 as Dev and PI 7.1 as QAS on one host.

Servers RAM is 32 GB and Paging space is set to 15 GB.

Dev instance was installed 2 months back and recently I installed QAS instance on it.

Now Dev instance is working fine but Java Engine of QAS instance is not working,It was working till yesterday.

ABAP engine of QAS is working fine.I checked all log files found below errors:

Tue Dec 29 11:39:21 2009

136.516: [GC 136.516: [ParNew: 459032K->125191K(524288K), 0.3480340 secs] 459032K->125191K(1922432K), 0.3482990 secs]

Tue Dec 29 11:39:35 2009

: [22618] 11:39:35 ***Warning: Compilation failed: com.sap.engine.services.webservices.jaxrpc.encoding.TypeMappingImpl.initializeRelations()V (rejected-by-exclude, not-retryable)

Tue Dec 29 11:39:37 2009

153.386: [GC 153.386: [ParNewJ

Tue Dec 29 11:39:38 2009

: 474759K->140824K(524288K), 0.3871060 secs] 474759K->140824K(1922432K), 0.3873330 secs]

[Thr 01] Tue Dec 29 11:31:50 2009

F [Thr 01] *** LOG => Signal 3 SIGQUIT.

F [Thr 01] *** LOG => Instance state is "Stopping the processes" (STOPPING @ 1, ACTIVE).

F [Thr 01] *** LOG => Stopping nodes: runlevel 3, phase 1.

F [Thr 01] *** WARNING => SfCR3DispClient::doRead: NiBufReceive failed (rc = -6 NIECONN_BROKEN) [sfxxr3c.hpp 187]

F [Thr 01] *** WARNING => SfCR3DispClient::doRead: Connection to the ABAP dispatcher broken - shutting down immediately. [sfxxr3c.hpp 190]

F [Thr 01] *** LOG => Send SIGQUIT to icm (pid 1220614).

F [Thr 01] *** LOG => Send STOP (80200000) to server0 (pid 1224806).

F [Thr 01] *** LOG => Process server0 stopping (pid 1224806).

F [Thr 01] *** LOG => Result from server0 for STOP: 0 ok, 00000000

From the logs I am feeling that memory is low for Java Engine of PI QAS.

So please suggest what all parameters I can set for it or there is some other reason of it.

Regards,

Shivam

Edited by: Shivam Mittal on Dec 29, 2009 12:36 PM