Skip to Content
0
Former Member
Dec 24, 2009 at 07:13 PM

hanging indent line cutoff when exporting to RTF

94 Views

Hello all,

I've got Crystal Reports XI R2 (11.5.8.826) and the back end is Oracle 11g. The existing report which I have inherited tries to design a hanging indent for a report simulating a table of contents, so if the title of a section/chapter is longer than one line, the following lines of that title indent, looking something as follows:

item1 xxxxxxx xxxxx xxxx xxxxx xxxx page 5

xxxxxx xxxxxxxx xxxx xxxxxxxxxx

xxxxx xxxxx xxxxx xxxxx xxxx xxx

item2 xxxx xxxxx xxxx xxxxx xxxxx page 29

xxxxxx xxxxxxxx xxxx xxx xxxxxx

item3 xxxxx xxxxxxx xxxxxxx xxxxxxx page 52

item4 xxxxx xxxxxxxx xxxxxxxxxxxxx page 71

The hanging indent is created using a negative indent for the First Line and positive indent for the overall Left indent in the paragraph tab in the Format Editor for that field. We get the desired result when the report is viewed in Crystal Reports, but when exported to Microsoft Word (RTF) or Rich Text Format (RTF), the first line (with the negative indent) loses a few characters. It cuts off the characters to the left of the Left indenation for the paragraph, the part with the negative indentation. We end up with:

m1 xxxxxxx xxxxx xxxx xxxxx xxxx page 5

xxxxxx xxxxxxxx xxxx xxxxxxxxxx

xxxxx xxxxx xxxxx xxxxx xxxx xxx

m2 xxxx xxxxx xxxx xxxxx xxxxx page 29

xxxxxx xxxxxxxx xxxx xxx xxxxxx

m3 xxxxx xxxxxxx xxxxxxx xxxxxxx page 52

m4 xxxxx xxxxxxxx xxxxxxxxxxxxx page 71

The cut off doesn't happen when I export using a Microsoft Word - Editable (RTF) format, but then I lose some formatting and horizontal rules/lines. The page number is a separate field/column so it's placement isn't really affected. The actual report is run from within a .NET Windows app, but the problem remains the same in the CR designer where I'm trying fix it.

I'm very new to Crystal Reports and the SAP community/forums; however I have made a good attempt to search the forums and Google for a solution. In the forums I did come across a thread dealing with the export to editable RTF losing format, but there wasn't really a solution.

I suppose there are two ways to solve: figure out the export issue, or perhaps try to create the indent some other way without using a negative indent.

I would appreciate any help. Sorry about the lengthy post, but I tried to make it clear (hope I've succeeded). Thank you!