Skip to Content
0
Former Member
Dec 18, 2009 at 04:25 PM

Cannot load UBL 2.0 XML documents into Message Mapping (PI 7.11)

293 Views

Hi,

Has anyone tried to load any of the UBL 2.0 XML documents into a Message Mapping in PI 7.11? We cannot get this to work without PI raising Java heap space errors within the Integration Builder client.

UBL 2.0 is an international open standard of Business to Business XML schemas, information on UBL is here:

http://www.oasis-open.org/committees/tc_home.php?wg_abbrev=ubl

The schemas I have loaded as exernal definitions are these:

http://docs.oasis-open.org/ubl/os-UBL-2.0.zip (including updates applied: http://docs.oasis-open.org/ubl/os-UBL-2.0-update-delta.zip)

The schemas all load perfectly and their full tree structures can be navigated ok (the high level main schemas "import" many common schema files, and that all works fine too). So no issues loading the External Definitions.

The issue I have is when we try and use one of the main schemas (such as Message "Order" within schema "UBL-Order-2.0.xsd") within a Message Mapping. The PI Integration Builder client fails with a Java Heap Space memory issue when we try to add the Message "Order" to the Message Mapping.

We adjusted the max heap size via the Exchange Profile from 512MB to 1536MB, but it made no difference (apart from using 1.6GB of RAM on our computers for PI instead of about 600MB !!), but it would still fail with an error saying not enough Java heap space on our client PCs.

The UBL schemas dont look any more complex than other schemas of similar size, such as xCBL (which UBL is based on), so I am thinking this is either a bug in PI, or there is something not quite right in the UBL schemas (although they load fine in XMLSpy, and load fine in PI 7.11 as external definitions without errors). It seems to me that PI is struggling to convert the UBL schema definitions into Java code when inserted into Message Mapping.

If anyone else has had this issue and found a way around it, please let me know. Or if anyone else wants to try and load the schemas I referenced above and see if the same happens in their system, that would be great. In the mean time, I am going to open a customer message with SAP.

Thanks,

Brendan