Skip to Content
avatar image
Former Member

Error during Initial Provisioning/Modify: Inconsistency with address

Hi all

During Initial Provisioning (and also after any modif) of some users I get the following errors:

E:Failed storing DDIC
E:Exception from Mod operation:Inconsistency with address
I:MX_PERSON has valid company address assignment.
I:The entry with MSKEY "69802" has MSKEYVALUE "COMPANY:SAP_IDM_DEFAULT".
E:Failed storing SAP*
E:Exception from Mod operation:Inconsistency with address
I:MX_PERSON has valid company address assignment.
I:The entry with MSKEY "69801" has MSKEYVALUE "COMPANY:SAP_IDM_DEFAULT".
E:Failed storing SAPCPIC
E:Exception from Mod operation:Inconsistency with address
I:MX_PERSON has valid company address assignment.
I:The entry with MSKEY "69802" has MSKEYVALUE "COMPANY:SAP_IDM_DEFAULT".

Surprisingly they're all "special users"; standard users are provisioned without errors (not related to the company address).

Unfortunately it's not mentioned in the logs which system has these inconsistencies, because mostly provisioning works well (for these users).

Questions:

1. Does anybody know how I can resolve or what combination of values lead to this error?

2. Where can I add a Debug-Line to see which system(s) fail?

Any help appreciated

BR

Michael

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Dec 19, 2009 at 02:53 PM

    Hello Michael,

    have you tried other companies than the default IdM company?

    I would try to add a script and then read out the repository information in the tasks/jobs/passes where the errors occour. E.g. direct on the MSKEYVALUE, logonuid, etc. Do not forget to return the value to the pass again, else an error would happen.

    Best regard

    Dominik

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      I solved this.

      First I added an Initialization script to the UpdateABAPUser-Pass which told me the repository and prints it as warning ot the job log.

      Then I took a look at these ABAP-Systems using SU01 and realized that SAP*, DDIC and SAPCPIC don't have the mandatory "Lastname" set, so SU01 says "Inconsistency with address" (DE: "Schiefstand bei Adresse").

      After I set this once on ABAP-side the UpdateABAPUser-Task ran fine.

      But still I would have expected that IdM sets this attribute as long as it is set on IdM-side, especially since it is mandatory in the destination system. At least it could provide a more informative error message.

      Thanks for any help.

      BR

      Michael