Skip to Content

*businessobjects.iviews doesnot start cos it has hard reference to *.common.commonservices

Hello,

We upgraded our Portal system to NW 7.5 and had problem with BO 4.2 integration.

We followed the note "1672422 - It's not possible to create an iView using the Business Objects Document List Template iview and the Enterprise Portal 7.3".

Undeployed com.sap.businessobjects.iviews using NWDS and deployed the downloaded one.

We have problems running sap.com/com.sap.businessobjects.iviews.

These are portal logs that we have.

Could not start managed object for application sap.com/com.sap.businessobjects.iviews

Application sap.com/com.sap.businessobjects.iviews cannot be started. Reason: it has hard reference to the following resources, which are currently not available on the system: hard to SAPPORTAL/com.sap.portal.common.commonservices (public) (f=true, cl=true); . In order to start the application, components that provide the missing resources should be successfully deployed.

How can I find com.sap.portal.common.commonservices app and deploy it to our portal?

Can you help about the issue, please?

Regards,

Yuksel AKCINAR

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Nov 24, 2016 at 11:02 AM

    Hello Yuksel

    I see this component in my portal (7.31)

    Its part of the EP-RUNTIME, do you have that component installed in your AS Java?

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 24, 2016 at 11:42 AM

    Hello Mario,

    I see this component on my other portal, too.

    But as I said according to the mentioned note 1672422 we undeployed com.sap.businessobjects.iviews and redeployed it.

    Now we cannot run com.sap.businessobjects.iviews because the referenced com.sap.portal.common.commonservices.

    How can we recover this? Can we transport this app only to our portal system?

    Regards,

    Yuksel AKCINAR

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 25, 2016 at 10:17 AM

    I can only imagine, as a test, to upgrade your SP version for your core EP components, this will re-deploy the commonservices. its a long shot but depending on the urgency you have is worth a try.

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 25, 2016 at 12:26 PM

    Hello Mario.

    Thank you for your answers.

    Portal consultant has done deployment of the application somehow and it is corrected now.

    Regards,

    Yuksel AKCINAR

    Add comment
    10|10000 characters needed characters exceeded