Skip to Content
0

*businessobjects.iviews doesnot start cos it has hard reference to *.common.commonservices

Nov 23, 2016 at 02:27 PM

448

avatar image

Hello,

We upgraded our Portal system to NW 7.5 and had problem with BO 4.2 integration.

We followed the note "1672422 - It's not possible to create an iView using the Business Objects Document List Template iview and the Enterprise Portal 7.3".

Undeployed com.sap.businessobjects.iviews using NWDS and deployed the downloaded one.

We have problems running sap.com/com.sap.businessobjects.iviews.

These are portal logs that we have.

Could not start managed object for application sap.com/com.sap.businessobjects.iviews

Application sap.com/com.sap.businessobjects.iviews cannot be started. Reason: it has hard reference to the following resources, which are currently not available on the system: hard to SAPPORTAL/com.sap.portal.common.commonservices (public) (f=true, cl=true); . In order to start the application, components that provide the missing resources should be successfully deployed.

How can I find com.sap.portal.common.commonservices app and deploy it to our portal?

Can you help about the issue, please?

Regards,

Yuksel AKCINAR

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Mario De Felipe Nov 24, 2016 at 11:02 AM
1

Hello Yuksel

I see this component in my portal (7.31)

Its part of the EP-RUNTIME, do you have that component installed in your AS Java?


portal.png (57.3 kB)
Share
10 |10000 characters needed characters left characters exceeded
Yuksel AKCINAR Nov 24, 2016 at 11:42 AM
0

Hello Mario,

I see this component on my other portal, too.

But as I said according to the mentioned note 1672422 we undeployed com.sap.businessobjects.iviews and redeployed it.

Now we cannot run com.sap.businessobjects.iviews because the referenced com.sap.portal.common.commonservices.

How can we recover this? Can we transport this app only to our portal system?

Regards,

Yuksel AKCINAR

Share
10 |10000 characters needed characters left characters exceeded
Mario De Felipe Nov 25, 2016 at 10:17 AM
0

I can only imagine, as a test, to upgrade your SP version for your core EP components, this will re-deploy the commonservices. its a long shot but depending on the urgency you have is worth a try.

Share
10 |10000 characters needed characters left characters exceeded
Yuksel AKCINAR Nov 25, 2016 at 12:26 PM
0

Hello Mario.

Thank you for your answers.

Portal consultant has done deployment of the application somehow and it is corrected now.

Regards,

Yuksel AKCINAR

Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Yuskel

We are facing the exact same issue . It would be great help if you can tell how exactly you managed to solve this.

Best regards

Vibhor

0

Hello Kinjal,

As I said my portal admin has done it using developer tools.

He has another portal system which has the same version.

I don't know the steps that he has done.

Regards,

Yuksel AKCINAR

0