Skip to Content

Copying standard Adobe Form to Z-form

Hello All,

I want to copy the expanse form PTRV_EXPENSE_FORM to ZPTRV_EXPENSE_FORM.

I did the following steps:

- I copied the Interface (PTRV_EXPENSE_FORM) to my Z-interface (ZPTRV_EXPENSE_FORM)

- I created a new form (ZPTRV_EXPENSE_FORM) based in my Z-interface.

- I copied the XML layout of standard form (PTRV_EXPENSE_FORM) and pasted it in the XML code of my Z-form.

- Then I saved.

The layout seems to be the same but the problem is that the context node is empty and was not copied from standard formu2026

How to get this context from the standard one?

Thank you in advance for your help.

Regards,

Moez.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Dec 14, 2009 at 05:38 PM

    Hi Moez.,

    If you want to copy the standard form then copying Interface & Form into Z <name> is enough. It is not required to copy the XML source to the new copy.

    The steps 1 & 2 you are enough and you can see the context after copying. That works fine, if the problem persists try copying it once again & activate it.

    Regards,

    Jhansi

    Add comment
    10|10000 characters needed characters exceeded

    • Good morning All,

      In fact i saw this thread but the proposed solution is not possible for me since I'm an Abapeur.

      The proposed solution is to restart the HTTP Provider service from within the Visual Administrator.

      I was working in a test environment.

      I tested it now in development environment and it works fine.

      Thank you for your help,

      Regards.