Skip to Content

ERM - MASS ROLE UPLOAD

Hi All,

when using the Mass role upload from SAP backend systems, i expect that all roles will be uploaded to the final stage in the role methodology inthe ERM and that they will be already generated.

After all, those roles already exists in the systems.

well, i see that this is not the case and i have to go through the different stages with every role.

is this indeed the system behavior or did we do somthing wrong ?

thanks

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Dec 14, 2009 at 12:53 PM

    Hi,

    same situation here. After mass role import there´s all of the defined methodology steps to be done.

    Is there a workaround for this?

    Reg,

    Ulrich

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi

      We did as you suggested but configured the approval stage in the methodology since the role is already approved and is in ECC PROD.

      Now we encountered a situation where we need to update the role in ERM as part of continuos maintainance (after upload) but we don't have the authorization option to enter and change it but only the "save" and "change history" push buttons.

      We changed bach the methodology to the relevant one with all the stages but still we can't maintain the uploaded role. the change in the methodology did not effect the role already uploaded.

      Do you have any suggestions regarding how we can fix this issue?

      Thank you

  • avatar image
    Former Member
    Dec 24, 2010 at 06:33 AM

    If you are on GRC 5.3 SP11 or higher the role template come with additional column "Set Role Methodology? [ Alphanumeric(50) ]"

    if you set it's value to "Yes", it make all the methodology steps as complete.

    For SP11, when you generate the files on ABAP, you won't get this column, but you can add it by yourself in template as functionality is already coded.

    Note: This will work for Parent and Single roles; if you have Child roles all stages will mark complete except Generate. you have to go to parent role and generate it's child.

    we tried and it worked for us, you can try your luck 😀

    Add comment
    10|10000 characters needed characters exceeded