Skip to Content
0
Former Member
Dec 13, 2009 at 06:59 AM

Dataflow Configuration Error-Run from Command Line Client-DataQuality XI R2

16 Views

Hi,

i m using dataquality XI R2-11.7.2 version, and trying to execute the job in schedule basis, presently configured in "RUN FROM A COMMAND LINE" dataquality xi scheduling(iq8clcu.exe), syntax, iq8clcu.xml and error log are as follows, if anyone knows to overcome the problem, please let me know and comments are really priceless. thanks in advance.

Syntax Statement to Command Prompt:

C:\dqxi\11_7\bin>iq8clcu.exe

-d C:\dqxi\11_7\repository\configuration_rules\projects\SAMPLE.xml

-l C:\dqxi\11_7\repository\Log\

-c C:\dqxi\11_7\bin\

-h localhost

-p 20004

-r C:\dqxi\11_7\repository\configuration_rules\

-s dqxiserver1_substitutions.xml

-b YES

-t BATCH

iq8clconfig.xml Statement

<?xml version="1.0" encoding="UTF-16"?>

<CLC>

<HOST_NAME>localhost</HOST_NAME>

<PORT_NUMBER>20004</PORT_NUMBER>

<REPOS>C:\dqxi\11_7\repository\configuration_rules</REPOS>

<RUN_DATAFLOW>

<DATAFLOW_TYPE>BATCH</DATAFLOW_TYPE>

<BLOCK>YES</BLOCK>

<SUBSTITUTION>dqxiserver1_substitutions.xml</SUBSTITUTION>

</RUN_DATAFLOW>

</CLC>

Error Log:

<?xml version="1.0" encoding="utf-16" ?>

- <LogFile>

<SequenceNumber>001</SequenceNumber>

<ProcessID>002360</ProcessID>

<Filename>clc_002360_001732_20091213_014350702.xml</Filename>

- <LogMsgs>

- <Msg>

<Date>12/13/2009</Date>

<Time>01:43:50.718</Time>

<ThreadID>001732</ThreadID>

<Type>INFO</Type>

<Source>RunBatchDataflow</Source>

<Description>Run Batch dataflow request sent: -h:localhost, -p:20004, -r:C:\dqxi\11_7\repository\configuration_rules, -d:C:\dqxi\11_7\repository\configuration_rules\projects\SAMPLE.xml, -s:dqxiserver1_substitutions.xml, -b:YES, waiting for response...</Description>

</Msg>

- <Msg>

<Date>12/13/2009</Date>

<Time>01:43:50.812</Time>

<ThreadID>001732</ThreadID>

<Type>ERROR</Type>

<Source>RunBatchDataflow</Source>

<Description><FL_RESPONSE> <DATAFLOW_ID>D20091213_014350765</DATAFLOW_ID> <ERROR>Error configuring dataflow. Check your dataflow log file for specifics.</ERROR></FL_RESPONSE></Description>

</Msg>

</LogMsgs>

</LogFile>

No clue about Error Configuring Dataflow.

Thanks,

Prasath