Skip to Content
0
Former Member
Dec 11, 2009 at 02:32 PM

B2B scenario with IDocs, sender system not in SLD

51 Views

Hello all

When sending a purchase order IDoc (ORDERS05) out of SAP ECC 6.0 I get the following error in SM58:

No service for system SAPPEE, client 200 in Integr ation Directory

Message no. SR053

Until now I did not register the SAP ECC 6.0 system in the SLD. Is this absolutely mandatory?

The RFC-Destinations work like a charm, the user (type C) and authorizations (for now SAP_ALL) should be ok (same settings in XI and SAP ECC system).

In the integration directory I defined a partner "IDOC_SENDER" with the following identifiers:

Agency = http://sap.com/xi/XI

Scheme = XIParty

Name = IDOC_SENDER

Agency = PEE_200 (SID with client from customers system)

Scheme = ALE#LI#LF

Name = 0000601140 (this is the vendor id from customers point of view)

Agency = AEE_200 (SID with client from vendors system)

Scheme = ALE#KU

Name = 0000001011 (this is the customer id from vendors point of view)

Within this partner "IDOC_SENDER" I defined a business service "Order" and assigned ORDERS.ORDERS05 as allowed outbound-interfaces.

Within this business service "Order" I defined a sender communication channel "Order_send_IDOC" with adapter type IDoc.

Based on this I created a receiver determination, interface determination, etc.

I also configured things in IDX1, IDX2. The metadata (structure info of idoc type ORDERS05) was successfully loaded.

Did I miss something? What to do to eliminate this error:

No service for system SAPPEE, client 200 in Integr ation Directory

Message no. SR053

???

Any help would be greatly appreciated!

Thanks in advance

Renaud