Skip to Content
0
Former Member
Dec 08, 2009 at 12:07 AM

AddCurrentValue does not successfully pass value to report.

83 Views

I am in the process of upgrading our legacy VB6 app, which is used simply to view reports, from Crystal 8.5 to 11.5 sp2. Per all examples I've found, the proper method of setting a parameter value is to use AddCurrentValue for a discrete-valued parameter. However, after updating the dll's to 11.5, the parameter value is not passed.

In Debug, I can see that the value is in the list of current values by pulling the indexed value; however, the report does not seem to actually use this value.

When I run the report in Crystal designer and set the parameter values, everything works fine and data is shown. However, when I run the same RPT through the VB6 app, data is not shown. I can then export to Crystal Reports, do a refresh and set the values, and data is shown.

In another .NET app, I use the methods SetCurrentValue; however, they are not available in VB6, for some reason.

I appreciate any help or insight you can provide.