Skip to Content

CORBA Connection to XMLForm failed...

Hi,

we are configuring the ADS and are unsuccesful. Here are the details:

-The Java instance (NW 70 SPS18) is installed on a seperate instance.

-The ERP 6.0 instance is ABAP only (NW70 SP15).

-OS is Solaris 10 64bit (supports ADS 32 bit acccording to the PAM),

-DB is Oracle 10.2

The RFC connection from ABAP to Java is working (HTTP 302 is returned)

The J2EE Destination is working (Error 404 is received but this is Ok accoding to manual)

The FP_PDF_TEST_00 program returns the version number of the ADS

The FP_TEST_00, FP_CHECK_DESTINATION_SERVICE (with and without RFC destionation) and FP_CHECK_HTTP_DATA_TRANSFER (with and without RFC destionation) all crash with the same error. This is also logged in the Default Trace of the Java instance:

"CORBA Connection to XMLForm failed, please verify the binaries are deployed to the os_libs directory and that the XML Form Module service is started". You may be running on a non-supported platform.

[Error Log file "2009.12.07.165337SAFP<USERNAME>.pdf" written to/usr/sap/<SID>/SYS/global//AdobeDocumentServices/renderErrorLog/errorFiles]"

Service XMLFormService: Native process (PID=0) /usr/sap/<SID>/JC##/j2ee/os_libs/adssap/XMLFormService/bin/XMLForm.exe terminated abnormally with error code 9

ld.so.1: XMLForm: fatal: libX11.so.4: open failed: No such file or directory

couldn't set locale correctly

The binaries are there however. When executing the XMLFom.exe from the shell using sidadm it returns pretty much the same errors as listed above. It's looking for the files in /bin/ instead of /usr/sap/<SID>/JC##/j2ee/os_libs/adssap/XMLFormService/bin but this could be that your not supposed to run the script from the command prompt.

interestingly enough, the generated PDF error files are ok. And in the PDF the message is "no errors reported".

I've renamed the adssap folder as suggested in some forums and the folder was regenerated. However, it made no difference.

I've configured ADS quite a few times now, but never ran into this. It seems to be an OS related problem, but I could use some help resolving it.

Cheers

marcel

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Best Answer
    Dec 15, 2009 at 10:58 AM

    Hi,

    problem "solved". The library libX11.so.4 is somehow needed to run the XMLForm.exe properly. This file is not in the os_libs directory but in the /usr/openwin/bin. By creating a symbolic link in the .../XMLFormsService/bin directory to this file the script executes properly and all the ADS tests (PF_TEST_00 etc) run fine.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      I am also facing the same error as shown below at

      The FP_TEST_00, FP_CHECK_DESTINATION_SERVICE and FP_CHECK_HTTP_DATA_TRANSFER.

      "CORBA Connection to XMLForm failed, please verify the binaries are deployed to the os_libs directory and that the XML Form Module service is started". You may be running on a non-supported platform.

      I didnt find the file libX11.so.4 file in my server. We are using HP-UX .

      Could you please let me know how to fix this problem.

      Thanks & Regards,

      Arun

  • Dec 15, 2010 at 04:33 PM

    We are using HP-UX and have the same problem. Is there a solution for HP-UX

    Add comment
    10|10000 characters needed characters exceeded