Skip to Content
avatar image
Former Member

Contract not created

Dear all,

We are in SRM 7.0 and we are trying to generate contracts directly in ECC (not in SRM) from an accepted bid.

We have implemented BADI BBP_DETERMINE_LOGSYS indicating the backend system (CV_LOGSYS = 'EX1MATMAS2'.)

Also implemented BADIs BBP_CTR_BE_CREATE (EV_PROCESS_TYPE = IS_PDEXT_HEADER-PROCESS_TYPE.) in SRM and BBP_CTR in ECC.

While debugging the BADIs we see that the data is transferred to ECC as we can see data on the segments of idocs BLAORD03 and COND_A....but then no contract is generated and no idoc also generated in BD87 or WE02....so, it is not possible to check what is the error.

Why is not generating the idoc?

Thanks

Ezequiel

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    avatar image
    Former Member
    Dec 08, 2009 at 12:06 PM

    Dear Ezequiel,

    I assume that your ERP release is lower than Ecc 6 EHP4, if so, check the outbound queues in SRM system via transaction SMQ1 and see if the queues are not blocked. If the queues in SRM are clear then check in ERP (Transaction SMQ2).

    If the backend is ECC 6 EHP4, then the mode of transfer should be XML and you need to check for it in SXMB_MONI

    Regards

    Sumat

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Ezequiel,

      Could you check if the Idocs are generated in ERP? I would suggest you to have a look at WE02 and look for BLAORD. If the Idoc isn't getting generated, then I would suggest debugging the issue.

      Regards,

      Sumat