Skip to Content

Enabling XRDP on SUSE Linux Enterprise Server 12 SP3 (HVM), SSD Volume Type

Hello Folks,

All these test activity I am carrying out on my AWS instance for my test purposes.

I am trying to enable XRDP on my SUSE Linux Enterprise Server 12 SP3 (HVM), SSD Volume Type instance but I am not getting success for activating the same. I followed this tutorial but no success : https://www.suse.com/documentation/sles-for-sap-12/book_s4s/data/cha_s4s_configure_rdp.html'

Previously : All these options were pretty simple & straight forward on SUSE Linux Enterprise Server 11 SP4 (HVM), SSD Volume Type.

Can anybody please through some light on this !! how to configure Linux instance so that I can continue with the installation of SAP B1 9.3.

I have referred this document : SAP Business One, version for SAP HANA Manual deployment on AWS for T&D purpose only [Confidential] created by EonSeok Bang 2016 but that document explains about configuring of SUSE Linux Enterprise Server 11 SP4 (HVM), SSD Volume Type

Current Issue : Getting the logging screen & then everything is blank, I can do anything on the screen. No UI nothing, Even I tried setting the display to 16-bit or 24-bit only but no success.

Jacob Tan Yatsea Li

So let me know your thoughts or suggest some document which explains how to configure Linux 12 for XRDP.

Thanks

Rahul Jain

Add comment
10|10000 characters needed characters exceeded

4 Answers

  • Best Answer
    Posted on Nov 09, 2018 at 09:55 PM

    My issue has been solved !!!


    Below are the steps I performed & it will be helpful for them who stumble upon the same issue.

    # zypper update ( to update SUSE Linux Ent. Server)
    # zypper install -t pattern gnome-basic
    # zypper install xrdp

    Enable VNC Remote Login
    # Open yast, Select "Network Services", Select first entry "Remote Administration with VNC"
    # Enable service

    Configure Window Manager to use Gnome
    Edit file /etc/sysconfig/windowmanager
    Change entry DEFAULT_WM="" to DEFAULT_WM="gnome

    Startup the RDP service and make it start automatically after Reboot
    # service xrdp start
    # chkconfig --set xrdp on

    # systemctl start xrdp
    # systemctl enable xrdp

    Above are the steps which I performed to get the activate & use RDP session through my windows, If in-case anybody have any question let me know I will be happy to assist you.

    Thanks again everyone for helping out.

    Regards,
    Rahul Jain

    Add comment
    10|10000 characters needed characters exceeded

  • Posted on Nov 22, 2018 at 12:37 AM

    Hi Rahul,

    I tried to install RDP using this guide on a AWS EC2 instance but always fail when running gnome-basic installation. The message I get is:

    zypper install -t pattern gnome-basic

    Refreshing service 'cloud_update'.

    Loading repository data...

    Reading installed packages...

    Pattern 'gnome-basic' not found.

    Resolving package dependencies...

    Nothing to do.

    I followed other guides and still can't get it working.

    Any advice?

    Add comment
    10|10000 characters needed characters exceeded

  • Posted on Aug 28, 2019 at 06:49 AM
    Willy Vidable

    If your on Suse v12-15 you should use the YaST repository in CLI to get gnome desktop.

    Check under Patterns in YaST (Tab to go down tree, shift-tab to go up tree) to Gnome-Basic and hit enter to install from their repository.


    You will still need to ensure the default WM is modified to gnome otherwise this will install all required packages for gnome GUI.

    Just reboot and connect to VNC/xRDP as per your preferred method.

    Add comment
    10|10000 characters needed characters exceeded

  • Posted on Nov 10, 2019 at 07:43 AM

    Hi Rahul

    We are trying this in SLES 12 SP4, but the steps as you mentioned is not solving the issue, any other things you did to resolve this?

    Add comment
    10|10000 characters needed characters exceeded