Skip to Content

Problems during the SAP Host Agent Installation/Initialization in Windows Server 2008 R2

Hello SAP experts.

I'm performing an SAP Web Dispatcher installation but in the process occured an issue during the SAP Host Agent installation phase of the Web Dispatcher installation's processing step (in the context of the SWPM). I have detected that the problem is that the Host Agent can not start and I have performed some troubleshooting with no success.

The user I'm using for the HA installation has administrator privileges and is a domain user.

I send you attached some of the troubleshooting activities I performed:

====================================================================

1. Trying with the restart of the HA after the installation via Windows CMD

2. Trying with the start of the services

3. Using Local System Account to start the services:

4. Log file in level 3:

-------------------- SAPHOSTAGENT information --------------------

kernel release 721

kernel make variant 721_REL

compiled on NT 6.1 7601 S x86 MS VC++ 14.00 for NTAMD64

compiled for 64 BIT

compilation mode Non-Unicode

compile time Oct 22 2018 21:59:17

patch number 40

latest change number 1879308

...

[Thr 3704] 'nthttpmonitor.pdb''n'

[Thr 3704] 'SAPCAR.exe''w'

[Thr 3704] 'SIGNATURE.SMF''n'

[Thr 3704] SetServiceStatus to 4 [Thr 3704] *** ERROR => StartService SAPHostControl failed [Error 1068: The dependency service or group failed to start. ] [HostControlW 182] [Thr 3704] *** ERROR => hostcontrol couldn't be started [HostExecServ 345]

[Thr 3704] *** ERROR => HostServer Start failed [HostServiceI 860]

[Thr 3704] SetServiceStatus to 1

[Thr 3468] hostexec/trace set to 3

5. t is important to mention the following:

  • For security reasons there is server hardening being used.
  • I already tried the installation of the HA (with the same installation medias I'm using for the server which is having problems) in other server with the same OS and worked fine (no major problems).
  • I tried installing older versions of the HA in the server where the problem is present and did not work.
  • I deactivate the anti-virus.
  • I generated a rule in the firewall to allow to the HA executable to pass trough it.

====================================================================

If there is needed further information, let me know it.

Thanks for your support in advance.

Best regards.

ha-restart.png (20.2 kB)
service-start1.png (42.6 kB)
service-start2.png (40.9 kB)
Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Best Answer
    Nov 07, 2018 at 10:07 AM

    The error is saying "The dependency service or group failed to start.".

    Did you identify the dependant services and try to start them manually?

    Add comment
    10|10000 characters needed characters exceeded

    • Hello Bartosz!

      Thanks for the reply, the problem was related to the server service which was not enable and started and it is a dependency for the SAP Host Control service.

      Best regards.

  • Nov 07, 2018 at 05:37 PM

    Hello Andrés,

    The SAPHostControl service should not run with "local system account".

    It should run as the "sapadm" user account.

    I would suggest installing the SAPHostAgent with the default settings...

    Regards,

    Isaías

    Add comment
    10|10000 characters needed characters exceeded